1
x = int(input('Введите x: '))
print('y =', 2 * pow(x, 0.5))
print('y =', pow(x + 2, 2))
print('z =', 14 * pow(x, 2) + 11 - 17)
2
import math
s, v_1, v_2 = int(input('Введите S: ')), int(input('Введите v1: ')), int(input('Введите v2: '))
print(math.ceil(s / (v_1 + v_2)))
И кстати, пример не правильный, т.к. когда вы используете просто команду input(), то она не преобразует строку в число, а оставляет ее строкой, то есть если вы ввели 5, то и переменная будет хранить значение '5' как строку(как слово), а строковый тип не поддерживает операцию перемножения саму на себя, то есть если вы умножите '5'(типа str) на '5'(типа str) это будет соответствовать умножению слова 'гриб' на слово 'дерево', а это невозможно.
Чтобы исправить эту ошибку нужно 'оборачивать' input() в int(), то есть должно получиться int(input()), как написал я.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая считывает произвольное количество чисел до стоп-слова "stop" и выводит, сколько раз среди них встречается первое введенное число (включая первое вхождение sample input: 8 1 6 1 6 10 8 10 1 2 9 4 2 6 3 4 9 3 1 6 10 8 4 9 10 2 3 1 stop sample output: 3
Внимание! Если программа не работает, обновите версию!
begin
var s1:=ReadlnString;
if s1='STOP' then Writeln(0)
else begin
var k:=1;
ReadSeqStringWhile(t->t<>'STOP').ForEach(w->if w=s1 then k+=1);
Writeln(k)
end
end.