Объяснение:
Язык не был указан, так что пишу на С++:
1)
#include <iostream>
using namespace std;
int main()
{
int buf, quantity = 0;
cin >> buf;
int sum = 0;
while (buf != 0) {
++quantity;
sum += buf;
cin >> buf;
}
cout << "Sum: " << sum << "\nAverage: " << sum / quantity;
}
2)
#include <iostream>
using namespace std;
int main()
{
int buf;
cin >> buf;
int max_num = buf;
while (buf != 0) {
if (max_num < buf) {
max_num = buf;
}
cin >> buf;
}
cout << "Max: " << max_num;
}
Program SumAndMul;
Uses Crt;
var a:array[1..10] of real;
i:integer;
sum,mul:longint;
begin
clrscr;
for i:=1 to 10 do
begin
write('Введите -', i,' число:' );
readln(a[i]);
end;
sum:=0;mul:=1;
for i:=1 to 10 do
begin
if (a[i]>0) then sum:=sum+a[i];
if (a[i]<0 ) then mul:=mul*a[i];
end;
writeln('Сумма положительных элементов: ',sum);
writeln('Произведение отрицательных элементов: ',mul);
readkey;
end.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая считает количество предложений во введенной строке и выводит его. предложение может заканчиваться на: . (точка) ; (точка с запятой) ? (вопросительный знак)
Внимание! Если программа не работает, обновите версию!
begin
var (s,k):=(ReadlnString,0);
for var i:=1 to s.Length do
if s[i] in ['.',';','?'] then k+=1;
Writeln('Количество предложений равно ',k)
end.