Pavel1545
?>

Скратч составьте программу, в которой кот идет слева направо до конца и говорит ! . затем поаорачивается на 90 груадусов, ждет 3 секунды, возвращается назад, превращается в летучую мышь(меняет костюм) и летитпо диагонали, спрашивает в конце "все понятно? ". при создании программы используйте скрипты 98 !

Информатика

Ответы

Баранов276

Объяснение:

1.Движение на метры,до конца экрана считай.

2.после движения всегда делать "говорить". привет.

3.После этого есть вкладка движение,после 2 делай повернутся на 90 град.

4.Ждать 3 секунды,И делай повторно 1.

5.Образы,делаешь мишь там,и меняешь образ.

6.Повернутся на 30-60 град. и делаешь 1.

7.Делаешь 2,только "Все понятно?"

nasrelza1012
Магический квадрат с n сторон

const
  mn = 16;
var
  p: Boolean;
procedure Swap(var a, b: Integer);
var
T: Integer;
begin
T := a; a := b; b := T
end;
procedure CreateMagic(n: Integer);
var
i, j, k, s, b, r, m: Integer;
a: Array[1.. mn, 1.. mn] Of Integer;
begin
  p := True; 
if Odd(n) Then
begin
i := 1; j := Succ(n div 2);
for k := 1 To Sqr(n) do
begin
a[i, j] := k;
if k mod n = 0 Then Inc(i)
Else
begin
Dec(i); Inc(j);
if i = 0 Then i := n;
if j > n Then j := 1
end
end;
  end
Else
if n mod 4 = 0 Then
begin
k := 1;
for i := 1 To n Do
for j := 1 To n Do
begin
a[i, j] := k; Inc(k)
end;
j := 2; m := n div 2;
for i := 1 To m Do
for k := 1 To m Div 2 Do
begin
if j = Succ(m) Then j := 2
Else
if j = (m + 2) Then j := 1;
s := Succ(n - i); b := Succ(n - j);
Swap(a[i, j], a[s, b]);
Swap(a[i, b], a[s, j]);
Inc(j, 2)
end
  end
Else
if n <> 2 Then
begin
k := 1;
for i := 1 To n Do
for j := 1 To n Do
begin
a[i, j] := k; Inc(k)
end;
  r := Pred(n div 2) div 2; m := n div 2;
for i := 1 To m Do
begin
j := i;
for k := 1 To r Do
begin
if j > m Then j := 1;
s := Succ(n - i); b := Succ(n - j);
Swap(a[i, j], a[s, b]);
Swap(a[i, b], a[s, j]);
Inc(j)
end
  end;
i := 1;
for k := 1 To m Do
begin
if j > m Then j := 1;
s := Succ(n - i);
Swap(a[i, j], a[s, j]);
Inc(i); Inc(j)
  end;
i := 1; j := r + 2;
for k := 1 To m Do
begin
if j > m Then j := 1;
b := Succ(n - j);
Swap(a[i, j], a[i, b]);
Inc(i); Inc(j)
end
  end
  Else p := False;
if p Then
begin
for i := 1 To n Do
begin
for j := 1 To n Do
Write(a[i, j]: 4);
WriteLn
end
end
Else
WriteLn( 'do not exists' )
end;
var
  n: Integer;
begin
WriteLn('n = '); ReadLn(n);
  CreateMagic(n);
end.
cosmetic89
Квадрат гипотенузы равен сумме квадратов двух катетов , а периметр всегда сумма длин всех сторон
Код C++
1#include <iostream>
2
3   int main()
4{   
5       setlocale (LC_ALL, "Russian");
6       int a = 0, b = 0, P = 0;
7
8       std::cout << "Введите катеты прямоугольника!" << std::endl;
9      std::cout << "a = "; std::cin >> a;
10     std::cout << "b = "; std::cin >> b;
11 
12     P = 2 * (a + b);
13
14     std::cout << "Периметр: " << P << std::endl;
15
16     system("pause");
17     return 0;
18 }

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Скратч составьте программу, в которой кот идет слева направо до конца и говорит ! . затем поаорачивается на 90 груадусов, ждет 3 секунды, возвращается назад, превращается в летучую мышь(меняет костюм) и летитпо диагонали, спрашивает в конце "все понятно? ". при создании программы используйте скрипты 98 !
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Li-111
maksmi
Людмила902
karasev17764
Emasterova77
cmdkotelniki
infosmolenskay
madjk
scraer198258
bryzgalovag
elozinskaya
Vera-zero281
Lebedeva1577
bezpalova2013
poch23420