molodoychek
?>

Составить программу обработки массива к, состоящего из 20 элементов. заполнить массив случайными числами в диапазоне от -5 до 25. все элементы массива к, значения которых находятся в интервале от -2 до 20 возвести в квадрат. измененный массив вывести на экран.

Информатика

Ответы

Vasilevich Fokin
PascalABC.NET 3.3.5, сборка 1660 от 20.04.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(20,-5,25); a.Println;
  a.Transform(t->t.Between(-2,20)? t*t : t); a.Println
end.

Пример
-3 5 14 -3 10 12 1 7 10 2 15 22 5 4 -3 21 3 -1 10 21
-3 25 196 -3 100 144 1 49 100 4 225 22 25 16 -3 21 9 1 100 21
ninazholnerova9

Основные понятия данных, информации, знаний.

К базовым понятиям, которые используются в экономической информатике, относятся: данные, информация и знания. Эти понятия часто используются как синонимы, однако между этими понятиями существуют принципиальные различия.

Термин данные происходит от слова data - факт, а информация (informatio) означает разъяснение, изложение, т.е. сведения или сообщение.

Данные - это совокупность сведений, зафиксированных на определенном носителе в форме, пригодной для постоянного хранения, передачи и обработки. Преобразование и обработка данных позволяет получить информацию.

Информация - это результат преобразования и анализа данных. Отличие информации от данных состоит в том, что данные - это фиксированные сведения о событиях и явлениях, которые хранятся на определенных носителях, а информация появляется в результате обработки данных при решении конкретных задач. Например, в базах данных хранятся различные данные, а по определенному за система управления базой данных выдает требуемую информацию.

Существуют и другие определения информации, например, информация – это сведения об объектах и явлениях окружающей среды, их параметрах, свойствах и состоянии, которые уменьшают имеющуюся о них степень неопределенности, неполноты знаний.Знания – это зафиксированная и проверенная практикой обработанная информация, которая использовалась и может многократно использоваться для принятия решений.

Знания – это вид информации, которая хранится в базе знаний и отображает знания специалиста в конкретной предметной области. Знания – это интеллектуальный капитал.

Формальные знания могут быть в виде документов (стандартов, нормативов), регламентирующих принятие решений или  учебников, инструкций с описанием решения задач.

Неформальные знания – это знания и опыт специалистов в определенной предметной области.

Необходимо отметить, что универсальных определений этих понятий (данных, информации, знаний) нет, они трактуются по-разному.

Принятия решений осуществляются на основе полученной информации и имеющихся знаний.

Принятие решений – это выбор наилучшего в некотором смысле варианта решения из множества допустимых на основании имеющейся информации.

Объяснение:

gabbro19975650
Const
n=5;m=10;
var
b:array[1..n,1..m]of integer;
i,j,k,buf,l:integer;
begin
    for i:=1 to n do
         begin
           writeln;
              for j:=1 to m do
                 begin
                    b[i,j]:=random(50);
                    write(b[i,j]:4);
                  end;
           end;
writeln;
for j:=1 to m do
   begin
      k:=0;
       for i:=1 to n-1 do
            if b[i,j]<b[i+1,j]then
                k:=k+1;
            if k=n-1 then
               buf:=buf+1;
    end;
k:=0;
for l:=2 to m do
   if l mod 2=0 then
     for i:=1 to n-1 do
       for j:=i+1 to n do
           if b[i,l]>b[j,l]then
               begin
                   k:=b[i,l];
                   b[i,l]:=b[j,l];
                   b[j,l]:=k;
                end;
writeln('увеличилось  ',m div 2-buf);
for i:=1 to n do
   begin
      writeln;
          for j:=1 to m do
             write(b[i,j]:4);
    end;
end.
       
                  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу обработки массива к, состоящего из 20 элементов. заполнить массив случайными числами в диапазоне от -5 до 25. все элементы массива к, значения которых находятся в интервале от -2 до 20 возвести в квадрат. измененный массив вывести на экран.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

fishka-sokol14
Nikolai_oksana
zubritskiy550
galinab1111326
kav511
det-skazka55
Platon
Anastasiya1537
Кирилл-Анна1023
Ruslanovich1217
byfetvostochniy
Alex-kustov
varvara-kulkova
eizmaylova6
MikhailNechaeva