bal4shovser16
?>

Составить программу вычисления произведения положительных и суммы отрицательных элементов массива a.проверить работу программы на заданном массиве a(11 на паскале

Информатика

Ответы

Сергей_Комарова899
Program p1;
uses crt;
var a:array[1..11] of integer;
i,p,s:integer;
begin

for i:=1 to 11 do begin
 a[i]:=random(30)-10;
 write(a[i]:4);
 end;
    p:=1;
 s:=0;
  for i:=1 to 11 do begin

    If a[i]>0 then begin
      p:=p*a[i];
     end;
     
     If a[i]<0 then
      s:=s+a[i];
      end;
writeln;
writeln('Произведение  :',p);
writeln('Сумма :',s);
end.
yuliasam

Привет из Шымкента!

1. Синтаксис яп это набор правил описывающие комбинации символов он важен для понимания компилятора или интерпретатор

2. Транслятор преобразовывает программы, написанною на одном языке программирования, в программу, состоящую из машинных команд.

3. Переменные эта контейнеры с данными нужны они для передачи данных по коду.

4. Таков синтаксис языков, допустим числа ты записываешь без кавычек они счетаются как int а строки str. По сути таким образом ты показываешь компилятору или интерпретатору что там строка.

nadejdashin508

1.  Алфавит языка в свою очередь состоит из: 1) латинских букв и символа подчеркивания: ABC...Zabc...z_ 2) арабских цифр: 012...9 3) 22 специальных символов: + ... $^ Символы алфавита используются для построения базовых элементов Pascal-программ - минимальных единиц языка, имеющих самостоятельный смысл.

2. Язык программирования имеет какой-то официальный стандарт. От которого можно в той или иной степени отклоняться. А иногда и нужно, чтобы язык не умер, перестав удовлетворять современным технологиям программирования.

Посмотрим на примере такого распространенного языка, как Паскаль.

Никлаус Вирт описал Паскаль в 1970 году. Будучи соавтором разработки языка Algol-68, он взял за основу алголоподобный синтаксис, в то время считавшийся наиболее удачным.

Первая реализация паскаля была сделана под конкретную машину и носила отпечаток требований её операционной системы. Сюда, например, относится требование, чтобы программа начиналась с оператора Program, содержащего указания на файлы ввода и вывода. С распространением паскаля на другие машины нужда в этих указаниях отпала, но некоторые школьные учителя, даже не зная о причинах, до сих пор уверяют учеников, что программа должна начинаться именно с program!

Шло время, программирование не стояло на месте. Возникали новые языки, создавались новые технологии, компьютеры проникали во все новые области. Появились персональные компьютеры. С этого момента Паскаль получил вторую жизнь. Понятный, быстро изучаемый и компилируемый в компактный код, это был отличный язык для "персоналок" с объемом памяти в 640 Кбайт. Но это был уже не тот, прежний Паскаль. Для работы с персоналками понадобилось его существенно дополнить. так возникла интегрированная система (среда) программирования Turbo Pascal. Именно система, потому что она включала компилятор с диалекта (т.е. с некоторой конкретной реализации) языка Паскаль, текстовый редактор, систему отладки, систему справок и поддержку выполнения программы.

Впоследствии возникли другие диалекты Паскаля, такие как входной язык системы Borland Delphi, язык Free Pascal, язык системы Pascal ABC и наконец, среда программирования PascalABC.NET, которая очень далеко ушла от Паскаля Никлауса Вирта, вобрав в себя лучшие черты и средства языков C#, Python и Haskell.

3. Каждый человек на протяжении своей жизни решает множество задач разной сложности. Но даже самые простые из задач выполняются последовательно, то есть за несколько шагов. Эту последовательность можно назвать алгоритмом. Последовательности бывают разные, но начинать их изучение лучше всего с линейных.  

Прежде чем приступить к рассмотрению основной темы статьи, следует сделать краткое отступление и сказать несколько слов про алгоритмический язык.  

Алгоритмический язык

Представьте, что человеку, работающему за компьютером, поставлена некая вычислительная задача. В языке программирования решение этой задачи выполняется с алгоритмизации. Решение предполагает:

— разбиение на этапы;

— разработку алгоритма;

— составление программы решения на алгоритмическом языке;

— ввод данных;

— отладку программы (возможны ошибки — их надо исправить);  

— выполнение на ПК;

— анализ результатов.

Алгоритмический язык является средством описания алгоритмов, а уже алгоритм, в свою очередь, представляет собой чёткое описание определённой последовательности действий, направленных на решение необходимой задачи.

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления произведения положительных и суммы отрицательных элементов массива a.проверить работу программы на заданном массиве a(11 на паскале
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

de1979nis
vsnimschikov391
barg562
Strelkov-Roman1263
ЛаринаЛощаков
Lapushkina
Щуплова Александр
catsk8
bei07
triumfmodern
izumrud153
mnkrasnova
lobutev
sergeev-alp5
Bordo