Поделитесь своими знаниями, ответьте на вопрос:
с задачей на Питоне или С++. Думаю, нужно использовать формулу суммы углов выпуклого многоугольника: 180 * (n - 2) Пытался решить перебором по разному, выдаёт Тайм Лимит. Сама задача: Даны углы. Определите, какое максимальное кол-во углов из них можно взять, чтобы составить выпуклый многоугольник. Входные данные Первая строка содержит целое число N (3 ≤ N ≤ 100) — количество углов Вторая строка содержит N целых чисел Ai (1 ≤ Ai ≤ 179) — величины углов в градусах. Выходные данные Выведите одно целое число - ответ на задачу. Если многоугольник невозможно сконструировать из имеющихся углов — выведите 0. Примеры входные данные 3 90 60 30 выходные данные 3 входные данные 4 179 1 90 18 выходные данные 0
begin
var k:=0;
var n:=ReadInteger();
var nmax:=0;
while n<>0 do begin
Inc(k);
if n mod 10 = 0 then
if n>nmax then nmax:=n;
n:=ReadInteger()
end;
var cntrl:=ReadInteger();
Writeln('Получено ',k,' чисел');
Writeln('Полученное контрольное значение: ',cntrl);
Writeln('Вычисленное контрольное значение: ',nmax);
if cntrl=nmax then Writeln('Контроль пройден')
else Writeln('Контроль не пройден')
end.
Тестовое решение:
53
16
40
9
10
32
74
0
40
Получено 7 чисел
Полученное контрольное значение: 40
Вычисленное контрольное значение: 40
Контроль пройден