verav75
?>

Составить программу вывода на экран среднего арифметического массива состоящего из 15 элементов

Информатика

Ответы

moisalexx7
Program TZ5;
const
n=15;
var
a:array [1..n] of integer;
i,b:integer;
begin
randomize;
for i:=1 to n do begin
 a[i]:=random (20);
 a[i]:=a[i]-10;
        writeln(i,'  ',a[i]);
end;
b:=0;
for i:=1 to n do
      b:=b+a[i];
writeln('srednee = ',b/n);
readln;
end.
Koshovkina1721

1.

1.572864

1024×768×2=1572864

1572864 байт = 1.572864 мегабайт (10⁶ байт)

2.

32х32=1024 точек.

то есть 1 байт должен хранить информацию о 2 точках.

8 бит в байте.

на одну точку приходится 4 бита

2 в 4 степени - 16 цветов

вроде так.

3.

2.5 кБайт = 2560 байт.

2560 байт / 2560 символов = 1 байт/символ

1 байт = 8 бит

8 бит = 256 вариантов (от 00000000 до 11111111).

ответ: 256 символов в алфавите.

4.

1) N = 2^i

256 = 2^i

i = 8 бит глубина кодирования одной буквы из 256-символьного алфавита

2) 30 * 70 * 5 = 10500 символов всего на 5 страницах текста

3) 10500 * 8 бит = 84000 бит нужно для кодирования всего текста

84000 / 8 = 10500 байт / 1024 = 10,25 Кбайт

ответ: 10,25 Кбайт нужно для кодирования всего текст

5. если я не ошибаюсь 12

Объяснение:

movlam11

ответ:Binary coding — 0010101101010010010101110100101

00101101101100010000101000100110

00101100001001101010100100101011

101010000

Informatica — 0011001001010111010011110101100

00101101101010110010010100101110

1010100100100110001001010

Kazakhstan — 0011010001001010011000110100101

00101010001010001010111000101110

10100101001010111

Rykhani jangyry — 0011101101100010010101000101000

10100101001010111010100100001010

00101001101001010010101110101000

00110001001011011011000100000111

00001110000101100010010110101101

10000111000011011001011110000111

00001110000101110

Объяснение:

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вывода на экран среднего арифметического массива состоящего из 15 элементов
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

istok11
bistrayakuhnya46
tsigankova2018
infooem
ТигранКалмыкова
Часть схемы пере информацию 5 букв
lezzzzka5510
карпова581
Александровна1244
shymilin19951783
rendikalogistic
AkimovaI1608
Евгеньевич-Куликов1614
merung
Романенко
Olga1509