Filintver
?>

Написать программу на c++.даны 2 стороны треугольника (а=4; с=3) и угол между ними (β=π/2 найти сторону (b), периметр(p), площадь(s), радиусы вписанной (r) и описанной (r) окружностей и оставшиеся углы (α, γ).​

Информатика

Ответы

Lidburg

Шестнадцатеричные цифры: 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A (10), B (11), C (12), D (13), E (14), F(15).

– По условию цифры не превосходят 6, тогда поразрядные суммы не превосходят 6 + 6 = C. Отвергаем вариант 1: в нем появилось F.

– Поразрядные суммы, как следует из предыдущего наблюдения, записываются одной цифрой. Поэтому не подходит вариант 2, в котором 3 цифры.

– Цифры в результате должны идти в порядке возрастания, чего нет в варианте 4, 7 > 6.


Остаётся единственный вариант: 3) 8B. Он получится, например, если исходные числа равны 35 и 56

bellenru

program z1;
var
i,j,m,k,z,x,l:integer;
begin
readln(m);
for i:=0 to m do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*4;
x:=x-1;
end; end;
if ((z<m) and (z*4>m)) then writeln(i);
if z=m then writeln(i-1);
end;
end.

 

program z2;
var
i,j,n,k,z,x,l:integer;
begin
readln(n);
for i:=0 to n do begin z:=1;
if i=0 then z:=1 else begin
x:=i;
while x<>0 do begin
z:=z*2;
x:=x-1;
end; end;
if ((z>n) and (z/2<n)) then writeln(i);
if z=n then writeln(i+1);
end;
end.

 

program z3;
var
i,j,n,k,z,x,s:integer;
begin
readln(n); s:=0;
for i:=1 to n do begin z:=1;
for j:=i to 2*i do
z:=z*j;
s:=s+z; end;
writeln(s);
end.

 

время 2 ночи 

...думаю пора спать ) 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу на c++.даны 2 стороны треугольника (а=4; с=3) и угол между ними (β=π/2 найти сторону (b), периметр(p), площадь(s), радиусы вписанной (r) и описанной (r) окружностей и оставшиеся углы (α, γ).​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

voen-torg
Levinalx4938
tushina2020
bereza81
osnovnoisklad3551
Belik-elena20111
Daniil1945
dimon198808744
Yevgenevich
Ramon22081983
MaratФам
fastprofit
naromanova
zrv85
Elshel8694