irinaphones8
?>

Напишите программу, которая подсчитывает, сколько различных чисел содержится в данном списке. входные данные программа получает на вход несколько чисел (не более 1000), записанных в одной строке через пробел. все числа по модулю не превосходят . выходные данные программа должна вывести единственное число - количество различных чисел среди данных. пример ввод вывод 2 5 1 3 1 5 (python)

Информатика

Ответы

васильевич

Например, можно действовать так: сначала отсортировать массив, а затем пройти по нему, подсчитывая количество элементов, которые не совпадают со следующим за ним элементом.

a = list(map(int, input().split()))

count = 1

a.sort()

for i in range(len(a) - 1):

    if a[i] != a[i + 1]:

        count += 1

print(count)

Но проще всего преобразовать массив в множество (set):

a = set(map(int, input().split()))

print(len(a))

Роман1406

формы представления звуковой информации

компьютер, имеющий звуковую плату, микрофон и акустическую систему, позволяет кодировать (оцифровывать), сохранять и воспроизводить звуковую информацию.

программы для работы со звуком можно условно разделить на две группы: программы-секвенсоры и программы, ориентированные на цифровые технологии записи звука — звуковые редакторы. midi-секвенсоры предназначены для создания и аранжировки музыки. кроме обычного сочинения музыки эффективное использование секвенсора требует от композитора-аранжировщика специальных инженерных знаний.

с звуковых редакторов звуковые файлы можно редактировать: добавлять голоса или музыкальные инструменты, а также разнообразные эффекты.

существуют программы распознавания речи, появляется возможность компьютером при голоса.

звук — это волна с изменяющейся амплитудой и частотой в диапазоне от 20 гц до 20 кгц. чем больше амплитуда, тем громче звук, чем больше частота, тем выше тон.

микрофон превращает звуковую волну в электрический сигнал, а звуковая плата кодирует его, превращая в последовательность нулей и единиц. точность преобразования определяется  разрешающей способностью  преобразователя (8 бит — 256 уровней, 16 бит — 65 536 уровней, 24 бита — 16 777 216 уровней) и числом преобразований (выборок) за 1 с —  частотой дискретизации. (рис.)

при частоте 8 кгц качество оцифрованного звука соответствует радиотрансляции, а при частоте 44,1 кгц — звучанию аудио-cd. студийное качество достигается при 96 или 192 кгц.

разрешение умножим на число выборок за 1 с и на время:

16 • 20 000 • 2 = 640 000 бит = 80 000 байт = 78 кбайт.

закодированный таким образом звуковой фрагмент может быть сохранен в формате  .wav.

в таблице размеры звуковых файлов длительностью звучания 1 с (в килобайтах) при различных разрешениях звуковой карты и частотах дискретизации. для стереозвука размер файла удваивается.

частота дискретизации, кгцразрешение8 бит16 бит24 бит65 53616 777 2167,81315,62523,43823,43846,87570,31344,143,06686,133129,19946,87593,750140,62593,750187,500281,250
fymukham
Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая подсчитывает, сколько различных чисел содержится в данном списке. входные данные программа получает на вход несколько чисел (не более 1000), записанных в одной строке через пробел. все числа по модулю не превосходят . выходные данные программа должна вывести единственное число - количество различных чисел среди данных. пример ввод вывод 2 5 1 3 1 5 (python)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

m79857860146895
udalova-yelena
idalbaev
drappaeva68
Telenkovav
borisovaks496
Tadevosyan
omigunova39
minasov19
miyulcha8077
vera141187
Chuhnin195107364
filternovo
dnikolay365
info2