Bi-1704
?>

Составить программу, которая запрашивает три целых числа и вычисляет сумму этих чисел, среднее арифметическое этих чисел.

Информатика

Ответы

vladimir72tatarkov1317
Var a, b, c:integer;
begin
read(a,b,c);
writeln(a+b+c);//сумма
writeln((a+b+c)/3);//ср. арифметическое
end.
annapiskun1

1) Пароль в этом коде - "zn4n1j4". Заменить при необходимости.

var

 i: integer;

 s: string;


begin

 i := 1;

 while i <= 5 do

 begin

   readln(s);

   if s = 'zn4n1j4' then

   begin

     writeln('Вход в систему разрешен');

     exit;

   end;

   writeln('Неверный пароль.');

 end;

 writeln('Пароль не был угадан 5 раз.');

end.


2) Используем операцию x mod 10 для получения последней цифры числа и x div 10 для "отбрасывания" последней цифры числа.

var

 x, ans: integer;


begin

 read(x);

 ans := 0;

 while x <> 0 do

 begin

   ans := ans + (x mod 10);

   x := x div 10;

 end;

 writeln(ans);

end.

Нина1449

а я разве их не решал

но ладнооо

1)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
Begin
clrscr;
readln(stroka);

i:=1;
repeat

val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;

until i=length(stroka);
x:=0;
for i:=1 to length(stroka) do x:=x+mas[i];
if x=10 then writeln('TRUE')
else writeln('ELSE');
end.

2 я не знаю как решать

3)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
begin
clrscr;
readln(stroka);
i:=1;
while i<=length(stroka) do begin
val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;
end;
x:=0;
for i:=1 to length(stroka) do x:=x+mas[i];
writeln(x);
end.

 4)

Program Pr1;
uses crt;
var stroka:string;
i,k,x:integer;
mas:array[byte] of integer;
begin
clrscr;
readln(stroka);
i:=1;
while i<=length(stroka) do begin
val(stroka[i],k,x);
mas[i]:=k;
i:=i+1;
end;
x:=0;
for i:=1 to length(stroka)-1 do
for k:=1 to length(stroka)-i do if mas[k]=mas[k+1] then x:=x+1;
if x>0 then writeln('TRUE')
else writeln('FALSE');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, которая запрашивает три целых числа и вычисляет сумму этих чисел, среднее арифметическое этих чисел.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

annaan-dr582
suny84
ayanrsadykov
Yeroshkina411
ryazantseva
Natali-0706
airon-082054
buriginast5
jablokov
Дмитриевич Бирковская69
yok887062
bmargarita
Playintim405374
mariapronina720126