Fateevsa9
?>

Имеется ряд последовательных целых положительных чисел от 120500 до 210800. определите сколько среди них чисел у которых сумма не равна 12. для получения результата напишите программу

Информатика

Ответы

alexfold

ответ : 89297

Код для вычисления представлен на Python'e


Имеется ряд последовательных целых положительных чисел от 120500 до 210800. определите сколько среди
igraparkGP51
//Pascal ABC.NET v3.1 сборка 1172

//1

Var
 s:string;
 i:integer;
begin
 readln(s);
 while i<length(s) do
 begin
 inc(i);
 if s[i]=',' then insert(' ',s,i+1);
 end;
 writeln(s);
end.

Пример ввода:
Some,awesome,test,text,
Пример вывода:
Some, awesome, test, text, 

//2

Var
 s:string;
 i,k,j:integer;
 ars:array of string;
begin
 readln(s);
 setlength(ars,length(s));
 k:=0;
 for i:=1 to length(s) do
 begin
  if (s[i]=' ') and (s[i+1]<>' ') and (i<>length(s)) then inc(k) else  ars[k]:=ars[k]+s[i];
 end;
 for i:=0 to k-1 do
  for j:=i+1 to k do
   if LowerCase(ars[i])>LowerCase(ars[j]) then
   begin
    s:=ars[i];
    ars[i]:=ars[j];
    ars[j]:=s;
   end;
 for i:=0 to k do
 writeln(ars[i]);
 end.

Пример ввода:
Очень              много яков и антилоп
Пример вывода:
антилоп
и
много
Очень
яков
Vik1744184
Uses graphABC;
var i: integer;
 
procedure Montain (x,y,k: integer);
begin
setpenwidth(1);
setpencolor(clgreen);
line(x,y,x-(30*k),y+(30*k));
line(x,y,x+(30*k),y+(30*k));
line(x+(30*k),y+(30*k),x-(30*k),y+(30*k));
floodfill(x,y+10,clgreen);
setpencolor(clbrown);
line(x,y,x-(20*k),y+(20*k));
line(x,y,x+(20*k),y+(20*k));
line(x+(20*k),y+(20*k),x-(20*k),y+(20*k));
floodfill(x,y+10,clbrown);
setpencolor(clwhite);
line(x,y,x-(10*k),y+(10*k));
line(x,y,x+(10*k),y+(10*k));
line(x+(10*k),y+(10*k),x-(10*k),y+(10*k));
floodfill(x,y+5,clwhite);
end;
 
begin
setpencolor(clnavy);
setwindowsize(900,600);
clearwindow(clnavy);
for i:=1 to 100 do
    begin
    setbrushcolor(rgb(random(255),random(255),random(255)));
    circle(random(700)+200,random(180),3);
    end;
setbrushcolor(clgreen);
rectangle(0,350,900,600);
setpencolor(clblue);
arc(900,1300,900,0,180);
floodfill(800,500,clblue);
Montain (500,150,7);
Montain (700,170,6);
Montain (300,200,5);
Montain (200,270,3);
Montain (600,270,3);
Montain (400,270,2);
Montain (50,300,2);
setpencolor(clteal);
arc(500,1250,900,80,180)
arc(800,1250,900,95,180);floodfill(100,500,clOlive);
setpencolor(clwhite);
arc(100,100,50,-84,180);
arc(70,130,40,-30,150);
floodfill(100,100,clwhite);
end.

плагиат ,конечно, но всё же

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Имеется ряд последовательных целых положительных чисел от 120500 до 210800. определите сколько среди них чисел у которых сумма не равна 12. для получения результата напишите программу
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Bolshakova Shigorina
akuznecov8989
ntinyakova
irina611901
Олег86
nsmirnova
Anastasiya Yevseeva948
mac4roc3781
ВостриковаСтародубцева1980
Vladimirovna1370
Александрович
YuRII1236
Владимирович
Popova-Erikhovich
Sacharov84