Написать программу, которая посчитает сумму пяти разных чисел, который может ввести пользователь самостоятельно. написать программу для трех случаев, с циклом while, repeat и for
2) Все записи в базе данных имеют: Если здесь вопрос понимать "Все записи в таблице реляционной БД имеют", то ответ, скорее всего, d) Одинаковое количество полей
3) Укажите правильную последовательность действий при работе с базами данных (составить последовательность из букв): c) Продумать структуру базы данных d) Дать имя каждому полю в базе данных a) Занести данные в таблицу b) Осуществить сортировку записей в базе данных
4) Поиск информации– это: a) выбор информации по определённым правилам
5) Примером базы данных может служить: Скорее всего b) Телефонный справочник, хотя и c) Энциклопедия тоже может быть
6) В каком из перечисленных типов полей, данные могут выглядеть таким образом: Да или Нет ? b) В логическом поле
7) В какой из перечисленных пар данные относятся к одному типу? a) 12.04.98 и 01/02/99; - тип дата b) ДА и TRUE (ИСТИНА); - логический тип
8) База Данных содержит информацию о каждой собаке из клуба собаководства: кличка, порода, дата рождения, пол, количестве медалей. Какого типа должны быть поля? d) текстовое, текстовое, дата, текстовое, числовое;
Возможно, такие ответы. Хотя многие вопросы некорректны.
Darialaza
09.12.2022
#include <cstdio> #include <cstring>
int main(void) { enum { MAX_BUF_SIZE = 100 };
char buf[MAX_BUF_SIZE]; scanf("%s", buf); int n = strlen(buf); int shift = 0; for (int i = 0; i < n; i++) { shift = (shift + buf[i] - '0') % 3; } shift = 3 - shift; int sel = -1; for (int i = 0; i < n; i++) { int tmp = buf[i] - '0' + shift; if (0 <= tmp && tmp <= 9) { sel = i; break; } } if (sel == -1) { for (int i = n - 1; i >= 0; i++) { int tmp = buf[i] - '0' - shift; if (0 <= tmp && tmp <= 9) { buf[i] -= shift; break; } } } else { buf[sel] += shift; while ('0' <= buf[sel] + 3 && buf[sel] + 3 <= '9') { buf[sel] += 3; } } printf("%s\n", buf); return 0; }
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Написать программу, которая посчитает сумму пяти разных чисел, который может ввести пользователь самостоятельно. написать программу для трех случаев, с циклом while, repeat и for
#include
using namespace std;
int main() {
bool repeat = true;
while (repeat) {
double число1, число2, число3, число4, число5;
cout << "'Введите числа: ";
cin >> число1 >> число2 >>число3 >> число4>>число5;
cout << "сумма: " << число1 + число2 +число3 + число4 + число5 << endl;
cout << "еще раз? (t/n) ";
char;
cin >>;
repeat = ( == 't');
}
return 0;
}