intermar2000
?>

Дана длина тела в миллиметрах. выразить ее через метры, сантиметры и миллиметры. например, 123456 мм = 123 м 45 см 6 мм. нужно составить программу для решения этой на с++))

Информатика

Ответы

Katkova

#include <iostream>

using namespace std;

int main() {

int lenght;

cout << "Lenght(mm): ";

cin >> lenght;

int cm, m, mm;

m = lenght / 1000;

cm = lenght / 10 - m * 100;

mm = lenght - lenght / 10 * 10;

cout << m << " meters " << cm << " centimeters " << mm << " millimeters";

return 0;

}

morozov1605
// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),1,99);
  a.Println;
  var k:=ReadInteger('k=');
  Writeln('Сумма чисел, кратных ',k,': ',
    a.Where(x->x mod k=0).Sum)
end.

Тестовое решение:
n= 18
45 17 36 15 65 17 97 44 49 43 60 51 66 72 18 55 71 85
k= 12
Сумма чисел, кратных 12: 168

// PascalABC.NET 3.1, сборка 1218 от 12.04.2016
begin
  var a:=ArrRandom(ReadInteger('n='),1,20);
  a.Println;
  a.Where((x,i)->x=i+1).Println
end.

Тестовое решение:
n= 16
17 2 1 14 20 19 10 3 9 15 14 4 2 7 2 16
2 9 16
stomcom01
1.
const n=20; 
var
  a:array[1..n] of integer;
  i,k,s:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(51)-25;
  Write(a[i]:4)
end;
writeln;
write('K = '); readln(k);
s:=0;
for i:=1 to n do 
 if a[i] mod k = 0 then s:=s+a[i];
Writeln('s = ',s);
end.

Пример:
Исходный массив:
18 -24 -4 -21 15 19 18 -16 -1 -8 7 -21 21 22 -24 -4 18 -16 24 4
K = 3
s = 24

2.
const n=10; 
var
  a:array[1..n] of integer;
  i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do begin
  a[i]:=Random(11);
  Write(a[i]:4)
end;
writeln;
writeln('Выбранные элементы:');
for i:=1 to n do 
 if a[i]<=i then Write(a[i]:4) else write(' ':4);
Writeln;
end.

Пример:
Исходный массив:
   9   1   2   8   2   7   1  10   8   3
Выбранные элементы:
       1   2       2       1       8   3

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дана длина тела в миллиметрах. выразить ее через метры, сантиметры и миллиметры. например, 123456 мм = 123 м 45 см 6 мм. нужно составить программу для решения этой на с++))
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

osipovasalex5316
Leonidovich_Elena771
Yevgenevna
alexseyzyablov
vallzh8328
ekasatkina
Aleksei1463
razumeiko0790
ganzashop
Валентинович133
ngz55
betepah
ann-perminova2008
Natalya1895
Nikolai710