emilbadalov
?>

Написать программу, которая проверяет, принадлежит ли точка (x, y) закрашенной области (x, y и r вводится пользователем)

Информатика

Ответы

svt5299

pascalabc:

program f0rwardirop;

var r, x,y: real;

b: boolean;

begin

  writeln('*   alphaeus is   *');

  write('ok, введите r =');   readln(r);

  write('теперь введите х =');   readln(x);

  write('и, наконец, введите y =');   readln(y);

  if x> =0 then  

      if (x*x+y*y < = r*r) then b: = true else b: =false

    else

      if (abs(x) < =r) and (abs(y) < =r) and (abs(x) < = abs(y)) then b: = true else b: =false;

  if b then   writeln('точка (',x,',',y,') принадлежит закрашенной области')

      else   writeln('точка (',x,',',y,') не принадлежит закрашенной области');

end.

avakarica

у меня получилось 61

Объяснение:

N = 2

counter = 1

for i in range(1, 10000000):

   binary = str(bin(N)[2:])

   print(binary)

   first_numbers = binary[:2]

   temp_list = list(binary)

   if temp_list[-1] == '0':

       temp_list[-1] = first_numbers

   print(temp_list)

   temp_list.reverse()

   print(temp_list)

   result_join = ''.join(temp_list)

   print(result_join)

   result_int = int(result_join, 2)

   if result_int == 127:

       print(result_int)

       print('counter', counter)

       break

   N += 1

   counter += 1

Если подумать, то можно этот код сократить. А так пишется недолго и легко (если решение правильное:) )

Igor1406

ответ:zywx

Объяснение:

Пишем код на python:

for x in range(2):

   for y in range(2):

       for w in range(2):

           for z in range(2):

               if (((x and (not y)) <= ((not z) or (not w))) and ((w <= x) or y)) == False:

                   print(x, y, w, z)

В результате его работы получаем таблицу истинности:

0 0 1 0

0 0 1 1

1 0 1 1

Сопоставляем нашу таблицу с таблицей в задание:

единственный столбик где есть 2 единицы и ноль в нашей таблице это столбик z ⇒ 1 столбик в таблице задания это z .

В нашей таблице вы видим, что нет строки со всеми единицами, следовательно в 2 столбике первой строке в таблице задания стоит 0, в нашей таблице мы видим, что есть одна строка с тремя единицами и одним 0 - этот ноль принадлежит столбику y ⇒ 2 столбик в таблице задания это y .

Остается 3 и 4 столбик, так как у нас в нашей таблице есть столбик со всеми единицами (столбик w) - 3 или 4 столбик таблицы задания должен полностью  состоять из единиц, так как в 4 есть 0 ⇒ 3 столбик состоит полностью из единиц ⇒ 3 столбик - w, а 4 столбик - x

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу, которая проверяет, принадлежит ли точка (x, y) закрашенной области (x, y и r вводится пользователем)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Nazart44446
argent
horina12
Barabanov Gerasimenko
art-03857
Светлана-Тигран
Кашихина
mkrtchyananaida6995
Negutsa_Kseniya524
ddobrov32133
alukyanov
diana-kampoteks
uglichwatch
olg14855767
vtarasyuk