Aleksei806
?>

Составить программу ввода с клавиатуры массива и вывода на экран элементов с четными отрицательными значениями.

Информатика

Ответы

kristina

var n,i:longint;

var a:array[1..10000000] of longint;

begin

writeln('Введите количество элементов массива');

readln(n);

for i:=1 to n do begin writeln('Введите элемент массива'); readln(a[i]); end;

for i:=1 to n do if( (a[i] mod 2 = 0) and (a[i]<0)) then writeln(a[i]);

end.

makscska22879
Меньше в доту катай, все знать будешь :)
1)
uses crt;
var s,s1,s2,s3,r1,r2:real;
begin
writeln ('Введите радиус первого (маленького) круга:');
read (r1);
writeln ('Введите радиус второго (Большего, чем первый) круга:');
read (r2);
//pi - 3.14
s:=3.14*r1*r2 ;
writeln (s);
//s1 - Площадь первого круга, s2 - второго, s3 - кольца
s1:=3.14*sqr(r1);
s2:=3.14*sqr(r2);
if (s1=0) or (s2=0)
then writeln ('Одна из площадей равна нулю')
else begin s3:=s2-s1 ;  
writeln (s3); end
end.

2)
uses crt;
var x,y,x1,y1 :integer;
begin
writeln ('Введите целое значение x:'); // В программе используются только целые числа !!
read (x);
if (x-1)<0 
then y:=4 
else y:=3;
writeln (y);
end.

3)uses crt;
var  a,b,c:real ;
begin
writeln ('Последовательно введите 3 числа :');
read (a,b,c);
if (a<>b) and (b<>c) and (a<>c) 
then writeln ('Числа не равны') 
else
if (a=b) and (b=c) and (a=c) 
then writeln ('Числа все равны между собой')
else
if (a=b) and (b<>c) 
then writeln (c) 
else
if (a=c) and (c<>b) 
then writeln (b) 
else
if (b=c) and (c<>a) 
then writeln (a) 
end.

P.s. Писал на Pascal ABC. Блок-схему сделаешь сам, она не сложная. Удачи, инвакир :D
alyonafialka
1. 2 Массивы объявляются тем же оператором, что и обычные переменные
2. Не корректный вопрос: индекс - это обращения к определенному элементу массива, а у самого массива индекса нет. В вариантах ответа ничего похожего на это нет.
3. 4 Массивы заполняются теми же операторами, что и обычные переменные
4. 1 Есть такой ввода в бейсике - конструкция READ DATA
5. 1 Выведется четвертый элемент массива, т.к. нумерация идет с нуля, и первый имеет номер 0, второй - 1, третий - 2, а четвертый - номер 3, который и запрашивается в выражении А(3)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу ввода с клавиатуры массива и вывода на экран элементов с четными отрицательными значениями.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mishagoride885
mel9152480522
koldunovan
info292
Ivanovich_Kostik898
КОРМИЛИЦЫНА
vladimirdoguzov
alina Korneev
ИП_Рамис873
Дил1779
Nikolaevna Malika1511
amaraks67
antongenfon
angelina-uj1350
saa002