Паскаль напишите программу которая выражает длину в миллиметрах через количество целых километров, метров, сантиметров и миллиметров например 2345678 2 345 67 8
PascalABC.NET 3.4.2, сборка 1826 от 07.10.2018Внимание! Если программа не работает, обновите версию!
begin
var x: int64;
Readln(x);
Format('{0:#0 000 00 0}', x).Println
end.
mos197653
07.02.2020
Попробуй Program PascalGuru; var s:string; f,t:text; function preobr(s:string):string;var i,j,p,n,sered:integer; gl,zp,slovo:string; m:array [1..80] of string;beginzp:='!?*,.'; gl:='аоуыэяеёюи'; p:=pos(' ',s); i:=0; repeat inc(i); slovo:=copy(s,1,p-1); m[i]:=slovo; delete(s,1,p); p:=pos(' ',s); until p=0; n:=i+1; m[n]:=s; for i:=1 to n do begin s:=m[i]; if pos(s[length(s)],zp)<>0 then p:=length(s)-1 else p:=length(s); sered:=(p div 2)+1; if (not odd(p)) or (p<3) then continue; if pos(s[1],gl)=0 then continue; if pos(s[sered],gl)=0 then continue; if pos(s[p],gl)=0 then continue; s[1]:=UpCase(s[1]); s[sered]:=UpCase(s[sered]); s[p]:=UpCase(s[p]); m[i]:=s+'('+s[1]+','+s[sered]+','+s[p]+')'; end; s:=''; for i:=1 to n do s:=s+m[i]+' '; preobr:=s;end; beginassign(f,'input.txt'); reset(f);assign(t,'output.txt'); rewrite(t); while not eof(f) do begin readln(f,s); writeln(t, preobr(s) ); end; writeln('Файл успешно записан...'); close(f);close(t);readln;end.
#код программы Ruby 22 s = "abbbab" n = 0 for r in 0..s.size-1 for l in 0..r t = s[l..r] if t.reverse == t n += 1 p [l,r,t,n] end end end
Ответить на вопрос
Поделитесь своими знаниями, ответьте на вопрос:
Паскаль напишите программу которая выражает длину в миллиметрах через количество целых километров, метров, сантиметров и миллиметров например 2345678 2 345 67 8
begin
var x: int64;
Readln(x);
Format('{0:#0 000 00 0}', x).Println
end.