Sadikova Gavrikov
?>

34 ! информатика ) pascal исследователи решили проанализировать участки днк двух образцов. каждый участок днк имеет некоторый состав нуклеотидов. нуклеотиды днк образованы одним из следующих азотистых оснований: аденин, гуанин, тимин, цитозин, которые кодируются в цепочках днк при заглавных букв по первой букве основания а, г, т, ц, соответственно. учёным определить долю расхождений в цепочках днк, если под расхождением понимается неравенство соответствующих нуклеотидов в цепочках, находящихся на одной позиции, считая от левого края. формат входных данных на вход программе подаётся целое число n (1≤n≤107 затем две строки в каждой из которых записана цепочка длиной n из латинских букв a, g, t, c, соответствующих азотистым основаниям. формат выходных данных единственное число — ответ на с точностью не ниже 10−7. система оценки за будут начисляться пропорционально количеству успешно пройденных тестов. sample input: 10 agtccgtcag agtgcctcag sample output: 0.2

Информатика

Ответы

Пронкина_TEST1682

Всегда рады Илона Маск

tatianamatsimoh

program Project1;

const

 n = 15;

var

 c: array[1..n] of real = (0, 1.25, -371, 0.5, -0.1, 1.2, -5, -172.3, 19783, -2.7, 43.51, 0, -0.02, 14.5, 123.7);

 // Переменная для хранения массива.

 i: integer; // Вс переменная для организации цикла.

 minelem: real; // Переменная для хранения значения элемента с минимальным значением.

 indmin: integer; // Переменная для хранения значения индекса минимального элемента.

 

begin

 writeln('Исходный массив:');

 for i:= 1 to n do      // Вывод массива в консоль.

   begin

     write(c[i]:9:2);

     if i mod 8 = 0 then

       writeln;

   end;

 writeln;

 minelem:= c[1];

 indmin:= 1;

 for i:= 2 to n do

   if c[i] < minelem then // Условие для нахождения элемента с минимальным значением.

     begin

       minelem:= c[i];

       indmin:= i; // Индекс элемента с минимальным значением.

     end;

 writeln('Минимальный элемент массива находится на ',indmin,' месте и равен ',minelem:0:2);

 Readln;

end.

Объяснение:

     В принципе я указал комментарии к некоторым действиям, так что должно быть понятно(комментарии потом лучше стереть). В отчет можешь сделать скриншот уже с результатом работы программы (мы так обычно делаем). Если остались вопросы пиши в комментарии.

Эрендженова
У меня 7 числа день рождения - информация понятная, актуальная если 7 число не наступило, и неактуально если полезная если я это говорю своему другу, и бесполезна если говорю мимо идущему прохожему которого вижу впервые, достоверная если я сказал правду, и недостоверная если солгал, полная если этого достаточно чтобы понять когда я родился(говорили про текущий месяц), и неполная если я просто так заикнулся не уточнив месяц, понятная если сказал на русском рускоязычному человек, непонятная если я сказал по русски тому кто русский не понимает(иностранцу к примеру). если смысл понятен то можно придумать много таких вариантов даже из одного примера, в принципе можно и на каждый случай отдельные приводить

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

34 ! информатика ) pascal исследователи решили проанализировать участки днк двух образцов. каждый участок днк имеет некоторый состав нуклеотидов. нуклеотиды днк образованы одним из следующих азотистых оснований: аденин, гуанин, тимин, цитозин, которые кодируются в цепочках днк при заглавных букв по первой букве основания а, г, т, ц, соответственно. учёным определить долю расхождений в цепочках днк, если под расхождением понимается неравенство соответствующих нуклеотидов в цепочках, находящихся на одной позиции, считая от левого края. формат входных данных на вход программе подаётся целое число n (1≤n≤107 затем две строки в каждой из которых записана цепочка длиной n из латинских букв a, g, t, c, соответствующих азотистым основаниям. формат выходных данных единственное число — ответ на с точностью не ниже 10−7. система оценки за будут начисляться пропорционально количеству успешно пройденных тестов. sample input: 10 agtccgtcag agtgcctcag sample output: 0.2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

manimen345
tkmandarin8376
Nadezhda
filimon131262
Nadirovich1317
snab54
bd201188
mez-omts-d5
familumid
галина
ss2911
Stanislavovna1237
tokarevmax
Сергеевна
tumanowivan2015509