evatautes
?>

Как решить эту по информатике? в этом году третий раз одна известная компания проводит соревнование по программированию искусственного интеллекта для игровых стратегий. в этот раз участникам предложили написать искусственный интеллект для командой хоккеистов. после проведения очередного тура, вася решил, что для дальнейшего улучшения своей стратегии необходимо просмотреть все бои с теми соперниками, которые сопоставимы с ним по проценту побед. задана таблица результатов боев в раунде. в каждой строке записаны ник соперника васи и итоговый счет. первое число показывает, сколько шайб забила стратегия васи, вторая — сколько шайб забила стратегия соперника. необходимо подсчитать процент побед каждого участника и вывести результат, отсортировав его в порядке неубывания процентов. если процент побед оказался одинаковым, то нужно упорядочить записи по никам лексикографически. формат ввода в первой строке входного файла записано целое число n (1 ≤ n ≤ 105) — количество записей в таблице. в каждой из последующих n строк через пробел записаны ник соперника, сколько забила васина команда и сколько забил соперник. гарантируется, что каждый ник — непустая строка, длина которой не превосходит 10 символов и состоящая из строчных букв латинского алфавита. так же известно, что никто из участников не забивал больше 1000 голов. формат вывода в первой строке выходного файла выведите количество соперников. в последующих строках выведите ник соперника и процент побед васиной команды с точностью не хуже шести знаков после запятой.

Информатика

Ответы

nikolai37

не так уж и трудно, если

program project2;

var

n,a,b,c,i,k,max,min: longint;

inp,outp: text;

begin

assign(inp,'input.txt');

reset(inp);

assign(outp,'output.txt');

rewrite(outp);

readln(inp,n);

max: =0;

min: =0;

c: =0;

for i: =1 to n do

begin

read(f1,a);

if i=1 then

b: =a;

if a> max then

max: =a;

k: =a-c;

c: =a;

if k< 0 then

begin

k: =abs(k);

min: =min+k;

if k> min then

min: =k;

end;

end;

max: =max-b;

write(outp,max,' ',min);

close(inp);

close(outp);

end.

espectr-m
Не знаю, на каком языке ты программируешь... я написал на C#
 using System;
namespace ConsoleApplication55{    class Program    {        static void Main(string[] args)        {            link:            Console.Write("Введите кол-во элементов  числовой последовательности: ");            int kol = Convert.ToInt32(Console.ReadLine());            if (kol > 100 || kol < 0)                goto link;            Random ran = new Random();            int[] array = new int[kol];            Console.WriteLine("\nПоследовательность чисел в строчку: ");            for (int i = 0; i < array.Length; i++)            {                array[i] = ran.Next(1, 1000);                Console.Write(array[i] + " ");            }            Console.Write("\n\nПоследовательность чисел, где каждое с новой строки:\n");            for (int i = 0; i < array.Length; i++)                Console.Write(array[i] + "\n");            Console.ReadKey();        }    }}
Смысл такой: ты делаешь массив, размер которого указываешь в начале, потом загружаешь  него рандомные(случайные) числа с периодом от 1 до 1000. После этого выводишь с цикла for элементы с условием, что после каждого элемента будет перевод строки(в С# это "\n"), в Паскале это writeln и т.д.
Виктория Нина

Объяснение:

Позиционная систе́ма счисле́ния (позиционная нумерация) — система счисления, в которой значение каждого числового знака (цифры) в записи числа зависит от его позиции (разряда).

Системы счисления в культуре

Индо-арабская

Арабская

Тамильская

Бирманская

Кхмерская

Лаосская

Монгольская

Тайская

Восточноазиатские

Китайская

Японская

Сучжоу

Корейская

Вьетнамская

Счётные палочки

Алфавитные

Абджадия

Армянская

Ариабхата

Кириллическая

Греческая

Грузинская

Эфиопская

Еврейская

Акшара-санкхья

Другие

Вавилонская

Египетская

Этрусская

Римская

Дунайская

Аттическая

Кипу

Майяская

Эгейская

Символы КППУ

Позиционные

2, 3, 4, 5, 6, 8, 10, 12, 16, 20, 60

Нега-позиционная

Симметричная

Смешанные системы

Фибоначчиева

Непозиционные

Единичная (унарная)

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Как решить эту по информатике? в этом году третий раз одна известная компания проводит соревнование по программированию искусственного интеллекта для игровых стратегий. в этот раз участникам предложили написать искусственный интеллект для командой хоккеистов. после проведения очередного тура, вася решил, что для дальнейшего улучшения своей стратегии необходимо просмотреть все бои с теми соперниками, которые сопоставимы с ним по проценту побед. задана таблица результатов боев в раунде. в каждой строке записаны ник соперника васи и итоговый счет. первое число показывает, сколько шайб забила стратегия васи, вторая — сколько шайб забила стратегия соперника. необходимо подсчитать процент побед каждого участника и вывести результат, отсортировав его в порядке неубывания процентов. если процент побед оказался одинаковым, то нужно упорядочить записи по никам лексикографически. формат ввода в первой строке входного файла записано целое число n (1 ≤ n ≤ 105) — количество записей в таблице. в каждой из последующих n строк через пробел записаны ник соперника, сколько забила васина команда и сколько забил соперник. гарантируется, что каждый ник — непустая строка, длина которой не превосходит 10 символов и состоящая из строчных букв латинского алфавита. так же известно, что никто из участников не забивал больше 1000 голов. формат вывода в первой строке выходного файла выведите количество соперников. в последующих строках выведите ник соперника и процент побед васиной команды с точностью не хуже шести знаков после запятой.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

slipu817838
AnzhelikaSlabii1705
vallzh8328
Artyukhin545
keykov35
artashhovhan
Марина1101
Larisa-Andrei
petrowanastya202081
starabanov
ea9824165833886
Климова1317
Yelena1458
kris5009646
tsarkovim