barekyan096140
?>

Требуется написать программу, определяющую, является ли четырехзначное натуральное число n палиндромом, т.е. числом, которое одинаково читается слева направо и справа налево. входные данные натуральное число n (1000 ≤ n ≤ 9999 выходные данные следует вывести слово «yes», если число n является палиндромом, или «no» – если нет.

Информатика

Ответы

Yulechkaakulova1993
PascalABC.NET 3.4.2, сборка 1837 от 11.10.2018Внимание! Если программа не работает, обновите версию!

begin

 var s := ReadInteger('n=').ToString;

 if (s[1] = s[4]) and (s[2] = s[3]) then Println('YES')

 else Println('NO')

end.

AleksandrIvanovich1273
1)
Var
n,m,max,min:integer;
Begin
write('Введите число: ');
readln(n);
min:=9;   
max:=0;
while n>0 do 
begin 
m:=n mod 10; 
if m<min then min:=m; 
if m>max then max:=m; 
n:=n div 10; end;   
writeln('Максимальное число: ',max);   
writeln('Минимальное число: ',min);
End.
2)
var
i,count: integer;
n,s:string;
begin
writeln('Введите число: ');
readln(s);
writeln('Введите цифру: ');
readln(n);
for i:=1 to length(s) do
if(s[i]=n)then
count:=count+1;
writeln('Количество раз, когда встречается цифра = ',count);
end.
a1rwalk3r

В n будем хранить количество чисел, которые ещё нужно вывести. a и b - предыдущее и текущее числа Фибоначчи. По определению, следующее число Фибоначчи равно сумме двух предыдущих, так что новое значение b будет a + b. Чтобы не заводить новую временную переменную, новое значение a можно будет найти, вычитая из нового b старое a, получится (a + b) - a = b.

Код процедуры:

procedure print_fib(n: integer);

var a, b, t: integer;

begin

   a := 0;

   b := 1;

   while n > 0 do

   begin

       write(b, ' ');

       b := a + b;

       a := b - a;

       n := n - 1;

   end;

end;

Пример основной программы:

begin

   print_fib(10)

end.

Вывод:

1 1 2 3 5 8 13 21 34 55

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Требуется написать программу, определяющую, является ли четырехзначное натуральное число n палиндромом, т.е. числом, которое одинаково читается слева направо и справа налево. входные данные натуральное число n (1000 ≤ n ≤ 9999 выходные данные следует вывести слово «yes», если число n является палиндромом, или «no» – если нет.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

smnra219
Mexx9050
vapebroshop
Lugovoi
Ионов202
Maloletkina-marina2
rkorneev19061
ksoboleva
Irinalobanowa
Бражинскене_Алексей
mlf26
snopovajulia
yanva
agaloan8
LYuBOV