Есартия52
?>

Напишите программу , настройки работы пароварки: у пользователя спрашивают , что он собирается готовить и в зависимости от ответа выдаётся рекомендация по времени приглотовления. рыба-20 минут овощи-30 минут мясо-40 минут остальные ответы-такое не готовим

Информатика

Ответы

Некрасов Валентина1097
-----------------------------
Напишите программу , настройки работы пароварки: у пользователя спрашивают , что он собирается готов
horina12
1. В приведенном коде ошибка. Не хватает ";" в третьей строке снизу.
2. Немного изменим ваш код и получим искомое значение x
Искомое число х = 16293

var
  x, y, a, b, k: integer;

begin
  k:=10000;
  repeat
    x:=k;
    a := 0; b := 0; y := 1;
    while x > 0 do
    begin
      if (x mod 10) mod 2 = 0
        then
        a := a * 10 + x mod 10
      else begin
        y := y * 10;
        b := b * 10 + x mod 10
      end;
      x := x div 10
    end;
    a := a * y + b;
    k := k + 1;
    until a = 26391;
    writeln(a:8, k-1:8); 
end.

 
Александр
1) F=Av(¬A&B)
По закону дистрибутивности раскроем скобки
(Av¬A)&(AvB)
Av¬A = 1, значит остаётся AvB

2) F =A&(¬AvB)
По тому же закону раскрываем скобки
(A&¬A)v(A&B)
A&¬A = 0, значит остаётся A&B

3. (AvB)&(¬BvA)&(¬CvB)
По закону склеивания (AvB)&(¬BvA) = A , получается, что выражение принимает вид
A&(¬CvB)
Можно раскрыть скобки, получим
A&¬C v A&B

4) F =(1v(AvB))v((AC)&1) 
Скобка (1v(AvB)) = 1, так как 1 v ЧТОУГОДНО = 1
Получаем выражение
1v((AC)&1) = 1, так как 1 v ЧТОУГОДНО = 1
ответ 1

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу , настройки работы пароварки: у пользователя спрашивают , что он собирается готовить и в зависимости от ответа выдаётся рекомендация по времени приглотовления. рыба-20 минут овощи-30 минут мясо-40 минут остальные ответы-такое не готовим
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alenih13
vikapar2646
andreevaanastsiyao82
sergeevich
Sharmel26
Любовь
larisau41
karpachevamarina
zazaza74
rytikovabs
Вадимовна
shuramuji
Анатольевна
ryadovboxing
Nekrasova