Dmitriy2211104
?>

Решить на с++ напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них. числа — целые от 1 до 1000. при решении можно пользоваться только целочисленными арифметическими операциями +, -, *, //, %, =. нельзя пользоваться нелинейными конструкциями: ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня. примеры: вход: 8 5 вывод: 8 вход : 5 8 вывод: 8 вход: 5 5 выход: 5

Информатика

Ответы

rmitin

#include <iostream>

int main()

{

int a, b;

std::cin >> a >> b;

std::cout << (a*(a / b) + b * (b / a)) / (b / a + a / b) << std::endl;

   return 0;

}


Главное 0 не вводите :)

borisov
Везде значения вводятся с клавиатуры!
на java
если изучали массив:
public class qwert {
public static void main(String args[]) {
Scanner scn = new Scanner(System.in);
int[] a = new int[5];
int k = 0;
for (int i = 0; i < 5; i++) {
a[i] = scn.nextInt();
k = k + a[i];
if (i == 4)
System.out.println(k/i);
}
}}
если не изучали массив:
public class qwert {
public static void main(String args[]) {
Scanner scn = new Scanner(System.in);
int a = scn.nextInt();
int b = scn.nextInt();
int c = scn.nextInt();
int d = scn.nextInt();
int e = scn.nextInt();
int s = (a + b + c + d + e) / 5;
System.out.println(s);
}}
на паскале через массив:
var a:array [1..5] of integer;
i:integer;
s:real;
begin
for i := 1 to 5 do
begin
readln(a[i]);
s := s + a[i];
if i = 5
then
write (s/i);
end;
end.
не через масивы:
var a,b,c,d,e :integer;
s:real;
begin
readln(a,b,c,d,e);
s := (a+b+c+d+e)/5;
write(s);
end.
catsk8

var

  s : string;

  i : integer;

  f : boolean;

begin

  readln (s);

  writeln ('Тут ', length (s), ' символов');

  f := true;  

for i := 1 to length (s) div 2 do

    if s[i] <> s[length (s) - i + 1] then f := false;

  writeln ('Это слово является перевертышем: ', f); //True/False

end.

 

var

  s : string;

  i, k, count : integer;

  c : char;

begin

  readln (s);

  count := 0;

  for i := 1 to length (s) do

    if s[i] <> ' ' then

    begin

       c := s[i];

       k := i + 1;

       break;

    end;

  for i := k to length (s) do

    if (s[i] = ' ') and (c <> ' ') then

    begin

       if s[i - 1] = c then inc (count);

       c := ' ';

    end

    else if c = ' ' then c := s[i];

  if (c <> ' ' ) and (s[length (s)] <> ' ') and (c = s[length (s)]) then inc (count);

  writeln (count);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить на с++ напишите программу, которая считывает два целых числа a и b и выводит наибольшее значение из них. числа — целые от 1 до 1000. при решении можно пользоваться только целочисленными арифметическими операциями +, -, *, //, %, =. нельзя пользоваться нелинейными конструкциями: ветвлениями, циклами, функциями вычисления модуля, извлечения квадратного корня. примеры: вход: 8 5 вывод: 8 вход : 5 8 вывод: 8 вход: 5 5 выход: 5
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Tane4ka2110
oldprince840
dovgash2
innaterenina
panasenko68
marusyamr
ilplakhotin8734
istok11
rn3ay8
linda3930
donliolik
gbelihina
stratocasterr34
Титова674
▲