osipovasalex5316
?>

Составить программу которое забрашивает четырёхзначное число и находит сумму цифр четырёхзначного числа и определяет делиться на 5.​

Информатика

Ответы

phmad7

program numsum;

uses

 SysUtils;

var

 n, i, sn: Integer;

 s: string;

begin

 Write ('Введите четырехзначное число: ');

 ReadLn (n);

 n := Abs (n);

 if (n > 9999) or (n < 1000) then begin

   WriteLn ('Введенное число не четырехзначное');

   ReadLn;

   Exit;

 end;

 s := IntToStr (n);

 sn := 0;

 for i := 1 to Length (s) do

   sn := sn + StrToInt (s [i]);

 WriteLn ('Сумма цифр числа = ', sn);

 if sn mod 5 = 0 then

   WriteLn ('Сумма цифр делится на 5')

 else

   WriteLn ('Сумма цифр не делится на 5');

 ReadLn;

end.

kosbart28

достоинства:

1 Стало довольно легко получить доступ к актуальной информации в любое время и в любом месте.

2 Раньше было очень трудно начать бизнес, нужно было много капитала, и был ограниченный доступ к деловой информации

3 Современные транспортные технологии позволяют очень легко путешествовать на большие расстояния.

недостатки:

1 Усиливается социальная изоляция, люди все больше времени проводят в видеоиграх, используют социальные сети.

2 Увеличение зависимости от современных инструментов, таких как калькуляторы и средства проверки правописания, снизило нашу креативность и интеллект.

vipppp19743355

1. Число не меньше 50 и четное: 50

2. Опечатка, вероятно. Либо наибольшее X - тогда 99, либо наименьшее натуральное x, и тогда это будет 1, либо НЕ меньше 100, тогда 101

3. Немного запутано, но по идее: число должно быть четным и меньше 10. Максимальное такое число: 8

4. X больше либо равен 7, или x меньше 6. Единственное число, которое НЕ подходит под эту формулу: 6

10. Обычное уравнение вида (4+3)^n+9 = 58 При том что n только натурален. Очевидно, что n = 2

17. Надо просмотреть каждую пару чисел и поставить плюсик, если первое больше 15 или второе больше 9. Я загнул пять пальцев, лучше меня перепроверить

25. У эсминца всего 2500 из которых 500 принадлежат также и фрегату. А всего-всего их 4500. Значит ТОЛЬКО эсминцу принадлежат 2000, ТОЛЬКО фрегату тоже 2000, а фрегату всего 2000+500 = 2500. Я понимаю, что ничего из этой писанины понять невозможно, так что прилагаю картиночку, написанную замороженной куриной лапой.

45. Столько писанины, а проще взять листочек в клеточку и самому побыть роботом, исполняя команды. Если у меня все верно, то за один цикл получается общее смещение на 1 вверх и 1 вправо. Значит за 5 циклов будет смещение (5,5) и чтоб переместиться в начало надо дать команду (-5,-5)

53. Третья строчка аналогична: a = 2*4 + 7*3. Любой второклассник скажет, что это 29. Четвертая строчка аналогична: b = 30-29 = 1. Таким образом, у нас a = 29, b = 1. А просят найти именно b. В ответ пишем 1


Объясните как это считать все к а к э т о де ла т ь. заранее целую в пупок. вот прям до вечера нужно

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу которое забрашивает четырёхзначное число и находит сумму цифр четырёхзначного числа и определяет делиться на 5.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tvtanya80
machkura
shalunovroman
proporcia46
oalexandrova75
boyarinovigor
astahova
Buninilya
ritckshulga20112
vtarasyuk
fastprofit
НиколаевнаОльга
Баринова
vahmistrova
Dmitrievich-Telishev
▲