astahova
?>

Задача 3 Написать программу, которая определяет, сколько раз в массиве случайных чисел А[1..100] встречается число X, введенное с клавиатуры.​

Информатика

Ответы

vovlyur

const

N = 100;

format = 3;

var

arr: array [1..N] of integer;

i: byte;

count: byte;

ch: Integer;

begin

writeln('Введите число: ');

read(ch);

randomize;

count := 0;

for i := 1 to N do

begin

arr[i] := random(20);

write(arr[i] : format);

if arr[i] = ch then

count := count + 1 ;

end;

writeln;

writeln('Число ', ch, ' встречается: ', count, ' раз');

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Задача 3 Написать программу, которая определяет, сколько раз в массиве случайных чисел А[1..100] встречается число X, введенное с клавиатуры.​
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

alex6543213090
Радецкая264
Olegmgu11986
osherbinin
Викторовна
tolyan791
Vrezh
astenSA
Popov Valentina1324
Wunkamnevniki13438
aleksey270593
MaratФам
kotovayaanastasia2069
ПодлеснаяМакарова1883
schumacher8