ibzaira
?>

Написать программу вычисления значения функции в паскале (мое 2)! (и объяснить, если не сложно)

Информатика

Ответы

Алексей Кирилл1094
Var
  x,f:real;
begin
  Write('Введите x: '); Readln(x);
  if (x>-2.4) and (x<5.7) then f:=sqr(x)
  else f:=4;
  Writeln('F=',f)
end.

var
  x,f:real;
begin
  Write('Введите x: '); Readln(x);
  if (x>0.2) and (x<0.9) then f:=sin(x)
  else f:=1;
  Writeln('F=',f)
end.

var
  a,b,c:real;
begin
  Write('Введите три числа: '); Readln(a,b,c);
  Write('Условие ',a,'<',b,'<',c);
  if (b>a) and (b<c) then Writeln(' выполняется.')
  else Writeln(' не выполняется.');
  Write('Условие ',b,'>',a,'>',c);
  if (a<b) and (a>c) then Writeln(' выполняется.')
  else Writeln(' не выполняется.')
end.
masha812
№1

var x, F: real;
begin
write('Введите х: ');
readln(x);
if ( x > -2.4 ) AND ( x < 5.7 ) then F := sqr(x)
else F := 4;
writeln('F = ', F);
end.

№2

var x, F: real;
begin
write('Введите х: ');
readln(x);
if ( x > 0.2 ) AND ( x < 0.9 ) then F := sin(x)
else F := 1;
writeln('F = ', F);
end.

№3

var a,b,c: real;
begin
write('Введите а: ');
readln(a);
write('Введите b: ');
readln(b);
write('Введите c: ');
readln(c);
if ( a < b ) AND ( b < c ) then writeln('a < b < c')
else
if ( b > a ) AND ( a > c ) then writeln('b > a > c')
else
writeln('Неравенства не выполняются');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу вычисления значения функции в паскале (мое 2)! (и объяснить, если не сложно)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

igor51766771
krikriska84
usmanovayanq2626
sergeevna
usmanovayanq2626
irnik65
Дарья16
ninakucherowa
Kuzminastia20038
Михайлович1309
X2755070
fotomuha1
Нана_Елена
asvirskiy26
NikolayGoncharov