Look7moscow
?>

Составить программу, объясните. ввести двухзначное число. если сумма цифр числа четная, то увеличить число на 2, в противном случае уменьшит на 2

Информатика

Ответы

osnovnoisklad3551

Объясняю: создаёте переменную, лучше целочисленную (int foo), после чего можно либо перевести число в строку и найти сумму цифр путём сложения двух символов (sum = bar[0] - '0' + bar[1] - '0'), либо с остатка от деления (конечно, это не очень красиво, но если известно, что число двузначное, то можно так: sum = (foo / 10) + (foo % 10)). Дальше банальная обработка условия: <если сумма чётная (if (sum % 2 == 0)), то увеличить число на 2 (foo += 2), иначе (else) уменьшить число на 2 (foo -= 2)>. После этого можете вывести результат на монитор (printf("%d\n", &sum)). :)

elozinskaya

ответ:

алгоритм- это конечная совокупность точно заданных правил решения произвольного класса или набор инструкций, описывающих порядок действий исполнителя для решения некоторой . в старой трактовке вместо слова «порядок» использовалось слово «последовательность», но по мере развития параллельности в работе компьютеров слово «последовательность» стали заменять более общим словом «порядок». независимые инструкции могут выполняться в произвольном порядке, параллельно, если это позволяют используемые исполнители.

ранее в языке писали «алгорифм», сейчас такое написание используется редко, но, тем не менее, имеет место исключение (нормальный алгорифм маркова).

часто в качестве исполнителя выступает компьютер, но понятие алгоритма необязательно относится к компьютерным программам, так, например, чётко описанный рецепт приготовления блюда также является алгоритмом, в таком случае исполнителем является человек (а может быть и некоторый механизм, ткацкий станок, и

можно выделить алгоритмы вычислительные (о них в основном идет далее речь), и . вычислительные по сути преобразуют некоторые начальные данные в выходные, реализуя вычисление некоторой функции. семантика алгоритмов существенным образом может отличаться и сводиться к выдаче необходимых воздействий либо в заданные моменты времени, либо в качестве реакции на внешние события (в этом случае, в отличие от вычислительного алгоритма, может оставаться корректным при бесконечном выполнении).

понятие алгоритма относится к первоначальным, основным, базисным понятиям . вычислительные процессы алгоритмического характера (арифметические действия над целыми числами, нахождение наибольшего общего делителя двух чисел и т. д.) известны человечеству с глубокой древности. однако в явном виде понятие алгоритма сформировалось лишь в начале xx века.

ocik1632933
Термин «информатика» появился в 1959 году в научном журнале communications of the acm[2], в котором луи фейн (louis fein) ратовал за создание высшей школы в области информатики аналогичной гарвардской бизнес-школе, созданной в 1921 году[3][уточнить]. обосновывая такое название школы, луи фейн ссылался на науку , которая так же как и информатика имеет прикладной и междисциплинарный характер, при этом имеет признаки, характерные для научной дисциплины. усилия луи фейна, численного аналитика джордж форсайта и других увенчались успехом: университеты пошли на создание программ, связанных с информатикой, начиная с университета пердью в 1962[4]. несмотря на своё название (от . computer science — компьютерная наука), большая часть научных направлений, связанных с информатикой, не включает изучение самих компьютеров. вследствие этого были предложены несколько альтернативных названий[5]. некоторые факультеты крупных университетов предпочитают термин вычислительная наука (computing science), чтобы подчеркнуть разницу между терминами. датский учёный питер наур предложил термин даталогия (datalogy)[6], чтобы отразить тот факт, что научная дисциплина оперирует данными и занимается обработкой данных, хотя и не обязательно с применением компьютеров. первым научным учреждением, включившим в название этот термин, был департамент даталогии (datalogy) в университете копенгагена, основанного в 1969 году, где работал питер наур, ставший первым профессором в даталогии (datalogy). этот термин используется в основном в скандинавских странах. в европе же часто используются термины, производные от сокращённого перевода фраз «автоматическая информация» (automatic information) (к примеру informazione automatica по-итальянски) и «информатика и » (information and mathematics), например, informatique (франция), informatik (германия), informatica (италия, нидерланды), informática (испания, португалия), informatika (в славянских языках) или pliroforiki (πληροφορική, что означает информатика) — в греции. подобные слова также были приняты в великобритании, например, школа информатики в университете эдинбурга[7]. в , , французском и языках в 1960-х годах была тенденция к замене термина «документация» терминами, имеющими в своей основе слово «информация»[8]. термин нем. informatik ввёл специалист карл штейнбух в статье informatik: automatische informationsverarbeitung (информатика: автоматическая обработка информации) 1957 года[9]. французский термин «informatique» введён в 1962 году филиппом дрейфусом, который также предложил перевод на ряд других европейских языков. в языке производной от термина «документация» стала документалистика и получили распространение термины научная и научно-техническая информация. термины «информология» и «информатика» предложены в 1962 году членом-корреспондентом ан александром харкевичем. основы информатики как науки были изложены в книге «основы научной информации» 1965 года, которая была переиздана в 1968 году уже под названием «основы информатики»[10]. во франции термин официально вошёл в употребление в 1966 году[11]. в языке термин нем. informatik имел вначале двойственное значение. так, в фрг[8] и великобритании[1] он был в значении «computer science», то есть означал всё, что связано с применением эвм, а в гдр, как и в основном по европе, обозначал науку по французской и модели.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу, объясните. ввести двухзначное число. если сумма цифр числа четная, то увеличить число на 2, в противном случае уменьшит на 2
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Azarenkoff
barekyan096140
dimoni86
jenn055
dmitrij-sp7
srvsm
Yarovitsin
andrew55588201824
Janaz842060
Николаевич
gnsnodir5001
samoilovcoc
mail2017
davidovalbert6
office426