Математическая модель (а также программа; зависит от того, что понимать под этапом формализации).
В учебнике выделяют такие этапы решения задачи на компьютере:
Исходные данные (результат - словесная информационная модель)Формализация (математическая модель)Алгоритмизация (алгоритм)Программирование (программа)Отладка, тестирование (уточнение модели)Выполнение расчетов (получение результатов)Нормальные люди понимают, что после формализации информация должна быть представлена на формальном языке, таких языком может быть как математический, так и язык программирования.
Поделитесь своими знаниями, ответьте на вопрос:
Напишите программу, которая получает возраст человека (целое число, не превышающее 120) и выводит этот возраст со словом «год», «года» или «лет». например, «21 год», «22 года», «25 лет». пример: введите возраст: 18 вам 18 лет. пример: введите возраст: 21вам 21 год. пример: введите возраст: 22вам 22 года. на c++ или паскаль
program Vozrasr;
var
AGE: integer;//Переменная возраста
begin
writeln('Введите любое число от 1 до 120');
Readln(AGE); //Ввод возраста
if (AGE < 1) or (AGE > 120) then
begin
writeln('ERROR!')
end
else
begin
case AGE of //для чисел от 11 до 20 создаем отд-ый кейс
11..20: Writeln('ответ: Мне ', AGE, ' лет');
Else //иначе если они не входят в диапазон от [11..20], то выполняется второй кейс
begin
case AGE mod 10 of //делим на 10 и получаем остаток =
1: Writeln('ответ: Мне ', AGE, ' год');
2..4: Writeln('ответ: Мне ', AGE, ' года');
0, 5..9: Writeln('ответ: Мне ', AGE, ' лет');
end;
end;
end;
end;
end.