svetlanam81
?>

Составьте программу, которая преобразует расстояния до некоторых ближайших к земле звёзд из световых лет в парсеки(1 пк = 3, 26 св. лет проксима центавра 4, 24 св. лет альфа центавра 4, 37 св. лет сириус 8, 58 св. лет эпсилон эридана 10, 52 св. лет процион 11, 4 св. лет эпсилон индейца 11, 82 св. лет тау кита 11, 89 св. лет тема : преобразование массива, информатика.

Информатика

Ответы

yanagitsina

#include <iostream>

int main() {

for(;;) {

double sg, pk_1 = 3.26;

std::cin >> sg; // Вводишь расстояние до звезды

std::cout << sg / pk_1  << std::endl;

if (sg == 0) break; // если вводишь 0, программа завершается

}

return 0;

}

// программа выводит на экран значение расстояния до звезды в парсеках

andreevaalisa

Материнская плата – основной компонент ПК, управляющий внутренними связями и взаимодействующий с внешними устройствами. МП влияет на производительность компьютера в целом, является главной платой ПК. Тип МП определяет общую производительность системы, а также возможности модернизации ПК и подключения дополнительных устройств.  

Структура типовой МП:

- сокет – разъем установки процессора на материнской плате

- микросхемы кэш-памяти второго уровня (внешней),

- слоты для установки модулей оперативной памяти,

- слоты для установки карт расширения,

- микросхема перепрограммируемой памяти, в которой хранятся программы БИОС, тестирования ПК, загрузки ОС, драйверы устройств,

- разъемы для подключения накопителей HDD, SSD.

Размеры материнской платы, а также отверстия внутри платы, которые соединяют ее с дном корпуса, стандартизованы.  

Объяснение:

Айай, надо самой задание делать

zrv85

import math

a = int(input('Введите первую сторону первого треугольника'))

b = int(input('Введите вторую сторону первого треугольника'))

c = int(input('Введите третью сторону первого треугольника'))

d = int(input('Введите первую сторону второго треугольника'))

e = int(input('Введите вторую сторону второго треугольника'))

f = int(input('Введите третью сторону второго треугольника'))

p = (a+b+c)/2

j = p*(p-a)*(p-b)*(p-c)

p2 = (d+e+f)/2

j2 = p*(p-d)*(p-e)*(p-f)

s = math.sqrt(j)

s2 = math.sqrt(j2)

if s == s2:

   print('эти треугольники равновеликии')

else:

   print('Foyl')

Объяснение:

В строчке print('эти треугольники равновеликии') можешь вписать что хочешь вместо эти треугольники равновеликии

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу, которая преобразует расстояния до некоторых ближайших к земле звёзд из световых лет в парсеки(1 пк = 3, 26 св. лет проксима центавра 4, 24 св. лет альфа центавра 4, 37 св. лет сириус 8, 58 св. лет эпсилон эридана 10, 52 св. лет процион 11, 4 св. лет эпсилон индейца 11, 82 св. лет тау кита 11, 89 св. лет тема : преобразование массива, информатика.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dkedrin74038
nalich8524
kifstd
msburmis
achernakov
seregina19706867
opel81
retropluse832
antonkovalev89
kate1610
sakalrip
ЕленаГерасимова
samiramoskva
themolodoy
ivanovmk1977