belka1976
?>

Сколько существует трёхзначных чисел, в записи которых встречается только одна двойка? составьте программу для получения правильного ответа.

Информатика

Ответы

Ludmila777020
Прикреплён скриншот, код и соответствующий вывод.Файл открывать любым текстовым редактором.Программа написана и скомпилирована в среде Visual Studioответ

225


Сколько существует трёхзначных чисел, в записи которых встречается только одна двойка? составьте про
papushinrv4985
Символов которых нет на клавиатуре это :
Математические  дроби - то есть это : ⅟ ½ ⅓ ¼ ⅕ ⅙ ⅐ ⅛ ⅑ ⅒ ⅔ ¾ ⅖ ⅗ ⅘ ⅚ ⅜ ⅝ ⅞.
Знаки тире как: длинное тире , цифровое тире , горизонтальная линия .
Математические символы такие как: ∫ ∬ ∭ ∮ ∯ ∰ ∱ ∲ ∳
∃ ∄ ∅ ∆ ∇ ∈ ∉ ∊ ∋ ∌ ∍ ∎ ∏ ∐ ∑ − ∓ ∔ ∕ ∖ ∗ ∘ ∙ √ ∛ ∜ ∝ ∟ ∠ ∡ ∢ ∣ ∤ ∥ ∦ ∧ ∨ ∩ ∪ ∴ ∵ ∶ ∷ ∸ ∹ ∺ ∻ ∼ ∽ ∾ ∿ ≀ ≁ ≂ ≃ ≄ ≅ ≆ ≇ ≈ ≉ ≊ ≋ ≌ ≍ ≎ ≏ ≐ ≑ ≒ ≓ ≔ ≕ ≖ ≗ ≘ ≙ ≚ ≛ ≜ ≝ ≞ ≟ ≠ ≡ ≢ ≣ ≤ ≥ ≦ ≧ ≨ ≩ ≪ ≫ ≬ ≭ ≮ ≯ ≰ ≱ ≲ ≳ ≴ ≵ ≶ ≷ ≸ ≹ ≺ ≻ ≼ ≽ ≾ ≿ ⊀ ⊁ ⊂ ⊃ ⊄ ⊅ ⊆ ⊇ ⊈ ⊉ ⊊ ⊋ ⊌ ⊍ ⊎ ⊏ ⊐ ⊑ ⊒ ⊓ ⊔ ⊕ ⊖ ⊗ ⊘ ⊙ ⊚ ⊛ ⊜ ⊝ ⊞ ⊟ ⊠ ⊡ ⊢ ⊣ ⊤ ⊥ ⊦ ⊧ ⊨ ⊩ ⊪ ⊫ ⊬ ⊭ ⊮ ⊯ ⊰ ⊱ ⊲ ⊳ ⊴ ⊵ ⊶ ⊷ ⊸ ⊹ ⊺ ⊻ ⊼ ⊽ ⊾ ⊿ ⋀ ⋁ ⋂ ⋃ ⋄ ⋅ ⋆ ⋇ ⋈ ⋉ ⋊ ⋋ ⋌ ⋍ ⋎ ⋏ ⋐ ⋑ ⋒ ⋓ ⋔ ⋕ ⋖ ⋗ ⋘ ⋙ ⋚ ⋛ ⋜ ⋝ ⋞ ⋟ ⋠ ⋡ ⋢ ⋣ ⋤ ⋥ ⋦ ⋧ ⋨ ⋩ ⋪ ⋫ ⋬ ⋭ ⋮ ⋯ ⋰ ⋱ ⋲ ⋳ ⋴ ⋵ ⋶ ⋷ ⋸ ⋹ ⋺ ⋻ ⋼ ⋽ ⋾ ⋿ ✕ ✖ ✚.
Символы как процент -‰
Римские цифры : Ⅰ Ⅱ Ⅲ Ⅳ Ⅴ Ⅵ Ⅶ Ⅷ Ⅸ Ⅹ Ⅺ Ⅻ
ⅰ ⅱ ⅲ ⅳ ⅴ ⅵ ⅶ ⅷ ⅸ ⅹ ⅺ ⅻ.
Цифры в кружках - ⓵ ⓶ ⓷ ⓸ ⓹ ⓺ ⓻ ⓼ ⓽ ⓾ ➊ ➋ ➌ ➍ ➎ ➏ ➐ ➑ ➒ ➓
⓪ ➀ ➁ ➂ ➃ ➄ ➅ ➆ ➇ ➈ ➉ ⑪ ⑫ ⑬ ⑭ ⑮ ⑯ ⑰ ⑱ ⑲ ⑳
❶ ❷ ❸ ❹ ❺ ❻ ❼ ❽ ❾ ❿ ⓫ ⓬ ⓭ ⓮ ⓯ ⓰ ⓱ ⓲ ⓳ ⓴
Латинские буквы в кружочках:
ⒶⒷⒸⒹⒺⒻⒼⒽⒾⒿⓀⓁⓂⓃⓄⓅⓆⓇⓈⓉⓊⓋⓌⓍⓎⓏ
ⓐⓑⓒⓓⓔⓕⓖⓗⓘⓙⓚⓛⓜⓝⓞⓟⓠⓡⓢⓣⓤⓥⓦⓧⓨⓩ
Знаки валютных купюр : $ € ¥ £ ƒ ₣ ¢ ¤ ฿ ₠ ₡ ₢ ₤
Смайлики:㋛ ソ ッ ヅ ツ ゾ シ ジ ッ ツ シ ン 〴 ت ☺ ☻ ☹
Рука , указательнйы палец и многое другое ( ✉ ✍ ✎ ✏ ✐ ✑ ✒,☚☛☜☝☞☟✌,✆ ☎ ☏,
pivenraisa
{ входит ли начало координат в треугольник }
type point = record
       x,y: real;
     end;
var s0,s: real;
    pts: array [1..3] of point;
    i: integer;
begin
{ считывание координат точек}
  for i:=1 to 3 do
   begin
     writeln('точка ',i,'  x ',' y ');
     write('         ');
     readln(pts[i].x,pts[i].y);
  end;
  { вычисляем площадь треугольника ABC  через векторное произведение }
  s0:=(pts[2].x-pts[1].x)*(pts[3].y-pts[1].y) - 
      (pts[3].x-pts[1].x)*(pts[2].y-pts[1].y);
  s0:=abs(s0);
{ вычисляем сумму площадей треугольников  из начала координат }
  s:=abs(pts[1].x*pts[2].y - pts[2].x*pts[1].y);
  s:=s+abs(pts[2].x*pts[3].y - pts[3].x*pts[2].y);
{ если  s > s0 , то начало координат вне треугольника }
  if s>s0 then writeln('начало координат вне треугольника')
  else writeln('начало координат внутри треугольника');
end.

На тестовой задаче:
точка 1  x  y 
             -1 -3
точка 2  x  y 
             -3 2
точка 3  x  y 
              4 3
начало координат внутри треугольника

точка 1  x  y
             -2 0
точка 2  x  y
              -3 2
точка 3  x  y
              4 3
начало координат вне треугольника

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Сколько существует трёхзначных чисел, в записи которых встречается только одна двойка? составьте программу для получения правильного ответа.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

uvarovig
alex091177443
Oksana-Kirakosyan1301
ПетровичЖивотовская1245
ksenia15-79
alexseyzyablov
reception
Ignateva737
ganzashop
Мусаев Игоревич371
annakuznetsova841
Вадимовна
energycomplect5914
Gennadievna bessonov
anovikovsr