komplekt7
?>

Написать программу в pascal: определить сколько раз в тексте встречается слог "ba"

Информатика

Ответы

nekataniyoleg
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

begin

 ReadlnString.ToLower.MatchValues('ba').Count.Println

end.

ПримерHubba-bubba goes to Abba's concert3
Tatarnikova1507
Пример на С# :
int N = int.Parse(Console.readline()); //ввод переменных 
int M = int.Parse(Console.readline());
int [] A = new int [N];//ввод массива и задание кол-ва мест в массиве
int t = 0;// доп переменная кол-во учеников нужного роста
random a = new random();// метод рандом (не указано как заполнять массив и                                              я выбрал рандомно
for (int i = 0: i < N - 1; i ++) // перебор и задание значений переменным 
{
A[i] = a.Next(150,200); // От 150 см до 200 см :)
}

for (int i = 0: i < N - 1; i ++) // опять перебор массива
{
if (A[i] < M)  // определение кол-ва учеников 
  {
   t ++;
   }
}
console.writeline("Количество учеников  " + t.toString()); // вывод переменной
Zaikinarusina
//1.
const god1=1626;
      god2=2015;            bank=0.07;      var
summa:real;
begin
summa:=24;
for var  i:=god1 to god2 do
summa:=summa+(summa*bank);
writeln(summa);
end.
//2.
var
a,b:integer; 
begin
read(a);
b:=0;
for var i:=1 to length(inttostr(a))  do begin
b:=b*10+a mod 10; a:=a div 10;
end;
writeln(b);
end.
//3.
const s=0.05;
var 
d:integer;
z:real;
begin
read(z);
d:=0;
repeat
inc(d);
z:=z-z*s;
until z<=30;
writeln(d);
end.
//4.
var
b,c:integer;
a:real;
begin
writeln('Кол-во $ и какой проц. годовых?');
readln(a,b);
c:=0;
while a<1000000 do begin
a:=a+a*(b/100);
inc(c);
end;
writeln(c);
end.
//5.
const max=100;var
a,b,c,d:integer;
begin
b:=0;
writeln('Кол-во машин?');
read(d);
writeln('Перечислите вес груза');
read(a);
c:=a;
for var i:=1  to d-1 do begin
read(a);
while c<=max do begin
inc(b);
c:=c+a;
end;
end;
writeln(b);
end.
//ABC Pascal

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу в pascal: определить сколько раз в тексте встречается слог "ba"
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

jstepanova
nastikak8
Kalashnikova
inulikb
Chistova-Dmitrii1162
shef3009
iracaenko153
jim2k
mira15963256
tanyatanyat
kazanoop
charlie79
Бочкарева Горохова1652
drevile57
Vladimirovich-Aleksandrovna96
▲