gorushko-tabak3
?>

Напишите программу, которая по введенному не более, чем четырехзначному числу k будет выдавать сумму его цифр.

Информатика

Ответы

lovely138887

var k:integer;

begin

write ('Введите не более, чем четырехзначное число: ');

readln (k);

writeln ('Сумма цифр равна: ',k div 1000 + k div 100 mod 10 + k mod 100 div 10 + k mod 10)

end.

Vladimirovna

Держи на приличном языке:

javascript:var K = parseInt(prompt().substr(0, 4)), сумма = 0; while (K > 0) { сумма += K % 10; K = K / 10 | 0; } alert(сумма);

Nikolaevich-Svetlana388

C самого детства-я считал, что в вычислительных машинах таилось нечто особенное, непонятное многим людям. В возрасте 6 лет я точно определился-компьютеры-моя любовь. Достаточно много времени с того момента, и я уже во многом разбираюсь, но до сих пор точно не определился, на какую специализацию пойти в будущем, ведь их так много! Информационная безопастность, прикладная информатика, программирование автоматизированных систем, web программирование, специалицазии на определенных языках программирования...-у меня разбегались глаза. Впрочем я и сегодня, занимаясь письмом этого сочинения до сих пор думаю о своем "Великом выборе".


Однако одно я могу заявить точно, с настоящей гордостью-"Я люблю компьютеры и хочу связать с ними свою жизнь!"

dentalfamily
// PascalABC.NET 3.0, сборка 1073
const
  nn=30;
  mm=30;
var
  a:array[1..mm,1..nn] of integer;
  m,n,i,j,k,s:integer;
begin
  Writeln('Введите число строк и столбцов массива: '); Read(m,n);
  Randomize;
  Writeln('*** Исходный массив ***');
  k:=0;
  for i:=1 to m do begin
    for j:=1 to n do begin
      a[i,j]:=Random(51)-25;
      Write(a[i,j]:4);
      if Odd(a[i,j]) then Inc(k)
    end;
    Writeln
  end;
  if k>5 then begin
    Writeln('Средние арифметические отрицательных элементов по строкам');
    for i:=1 to m do begin
      s:=0; k:=0;
      for j:=1 to n do
        if a[i,j]<0 then begin Inc(k); s:=s+a[i,j] end;
      if k>0 then Writeln(s/k:9:5) else Writeln('  0.00000');
    end
  end
  else begin
    Writeln('*** Результирующий массив ***');
    for i:=1 to m do begin
      for j:=1 to n do begin a[i,j]:=2*a[i,j]; Write(a[i,j]:4) end;
    Writeln
    end
  end
end.

Тестовые решения:
Введите число строк и столбцов массива:
8 6
*** Исходный массив ***
 -16  -8  -1  24 -22   1
  -9 -20 -25  13 -11  10
 -15  10 -12  20 -22   3
  -6  25  -3  25 -14  22
  24  -4  24  17  -4 -17
 -23  -9 -22   1 -18 -13
 -12  13   6 -16   2 -13
  19   8 -22  14  -3   4
Средние арифметические отрицательных элементов по строкам
-11.75000
-16.25000
-16.33333
 -7.66667
 -8.33333
-17.00000
-13.66667
-12.50000

Введите число строк и столбцов массива:
3 5
*** Исходный массив ***
   3  24 -21 -22  -8
 -21  14 -22   0 -22
  15 -16  -2   6  22
*** Результирующий массив ***
   6  48 -42 -44 -16
 -42  28 -44   0 -44
  30 -32  -4  12  44

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу, которая по введенному не более, чем четырехзначному числу k будет выдавать сумму его цифр.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

dokmak140652
sbarichev330
marinarodina90
mushatolga
ekattatarenko
far-yuliya128
grekova5
Maria095096
cetarbkilork82
tatiana2676
oknacrow
zsa100
koam20167459
doorhan42n6868
voen-torg