kryukovaem
?>

Напишите программу в pascal границы диапазона найти сумму тех чисел которые четные

Информатика

Ответы

thecoffeeowl

var a,b,i,z,x:integer;

q:array [1..20] of integer;

begin

 write('Верхняя граница='); readln(a);

 write('Нижняя граница='); readln(b); x:=a-b; randomize;

 for i:=1 to 20 do

 begin  

   q[i]:=random(x)+b;

   write(q[i],' ');

   if (q[i]mod 2=0) then z:=z+q[i];

 end;

 writeln;

 write('Сумма четных чисел=',z);

end.

bruise6

в 3 раза

Объяснение:

V = K * i, где  

V - информационный объём изображения (размер файла, содержащего изображение)

K - количество точек (пикселей )

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

N = 2^i, где  

N - количество цветов в палитре

i - глубина цвета (число бит, используемых для записи цвета одного пикселя)

^ - знак степени

Т.к. изображение одно и тоже, то количество точек в них одинаковое (K).

2^i = 256

i = 8 бит для  p2.bmp

i = 24 бит для p1.bmp

Для p2.bmp  V = 8K

Для p1.bmp V = 24K

24 / 8 = 3

В 3 раза будет меньше информационный объём файла p2.bmp.

chechina6646
1.)
16 = 2^4
Получается, что рисунок p2.bmp - четырехразрядный, т.е. 1 пиксель занимает 4 бит памяти. 24/4=6. ответ: в 6 раз.

2.)
64*512=32768 - кол-во пикселей в изображении.
32 Кбайт = 32768 байт.
32768/32768=1 байт = 8 бит - память, занимаемая 1 пикселем.
2^8=256. ответ: 256 цветов.

3.)
25*30 см = 10*12 дюймов = 120 дюймов^2
10*12*300*300*3=32400000 байт = 31640 Кбайт = 30 Мбайт.
ответ: 30 Мбайт.

4.)
65536 = 2^16
1 пиксель занимает 16 бит = 2 байта.
1280*1024*2 = 2621440 байт = 2560 Кбайт = 2,5 Мбайт.
ответ: 2,5 Мбайт.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу в pascal границы диапазона найти сумму тех чисел которые четные
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

mariy-y34
Yeroshkina411
mvolkov8
slastena69678
VladimirovnaViktorovich
nikitavertiev98400
sveremeev816
Денис_Петровна
Кристина_Memmedov
Takhmina-Komarova1415
Д.О. Игорь
АлександрАнатолий
darialyagina
Сорокина
a-zotova