alvs9
?>

Составьте программу определяющую высоту растения через 6 месяцев если за месяц прирост составляет 5%, а начальная высота 20см

Информатика

Ответы

dovgash2
(20+20*1.05^6) - выражение, позволяющее получить результат
На некоторых языках программирования можно возвести число в степень в одну операцию, а в некоторых эту функцию придётся писать самому
Sergeevich-irina
Program z;
var a:array [1..15] of integer; i,k,s,j,n:integer;
begin

writeln('Начальная последовательность');
for i:=1 to 15 do
begin
a[i]:=random(1,100);
write(a[i], ' ');
end;
for j:=1 to 14 do
for i:=1 to 14 do
if a[i]>a[i+1] then
begin
k:=a[i];
a[i]:=a[i+1];
a[i+1]:=k
end;
writeln;
writeln('Отсортированная последовательность');
for i:=1 to 15 do
write(a[i], ' ');
writeln;
write('Введите N (а[1]<N<a[15]) ');
read(n);
for i:=1 to 15 do
begin
if (a[i]=n) or (a[1]>n) or (a[15]<n) then
begin
while (a[i]=n) or (a[1]>n) or (a[15]<n) do
begin
writeln('Ошибака! Число N не длжно совпадать с элементами последвовательности и а[1]<N<a[15]');
write('Введите N (а[1]<N<a[15]) '); read(n);
end;
end;
if a[i]<n then s:=a[i]+s;
end;
write('Cумму последовательности меньших N = ',s);
end.
xarfagr
Program raznost_xy;
var x, y:integer;
begin
write ('Введите число х = ');
readln (x);
write ('Введите число у = ');
readln (y);

if (x>0) and (y>0) then
  begin
    if abs(x)>abs(y) then write ('x-y > 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y < 0');
  end;
      
if (x<0) and (y<0) then
  begin
    if abs(x)>abs(y) then write ('x-y < 0');
    if abs(x)=abs(y) then write ('x-y = 0');
    if abs(x)<abs(y) then write ('x-y > 0');
  end;

if (x=0) and (y=0) then write ('x-y = 0');
if (x>0) and (y<0) then write ('x-y > 0');
if (x<0) and (y>0) then write ('x-y < 0');
if (x=0) and (y>0) then write ('x-y < 0');
if (x=0) and (y<0) then write ('x-y > 0');
if (x>0) and (y=0) then write ('x-y > 0');
if (x<0) and (y=0) then write ('x-y < 0');
end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составьте программу определяющую высоту растения через 6 месяцев если за месяц прирост составляет 5%, а начальная высота 20см
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

pechinin
Nadegdasb
yrgenson2011801
Константиновна
zakupki
Борисовна_Кашутина
margusha1974
dkedrin74038
ev27076878
lmedintseva6
dokurova634
korotinadasha07
marver201040
oyudina
boldireve617
▲