Stenenko
?>

Дано число а заменить это число удвоенным произведением если оно нечетное. скок сижу не могу сделать program xz; var a: integer; begin; writeln ('введите число'); readln (a); if a mod 2=0 then writeln ('число четное') else a: =a*2; writeln ('удвоенное нечетное число'); readln; end. вот здесь где-то ошибка

Информатика

Ответы

tretyakovamarina201155

Ошибка внизу там где вывод данных на экран

writeln ('удвоенное нечетно число =', a);

а так в целом ты молодец.

maxborod
12356 ворот и и гттол
Олтр
Shago

32768

Объяснение:

Данная незамысловатая функция Excel VBA формирует строку, согласно условию.

Function replstr(str As String, n As Integer) As String

Dim a(1 To 3), b(1 To 3) As String, i, j As Integer

a(1) = "A": a(2) = "B": a(3) = "AB"

b(1) = "AB": b(2) = "AB": b(3) = "A"

For i = 1 To n

j = (i - 1) Mod 3 + 1

str = Replace(str, a(j), b(j))

Next

replstr = str

End Function

Аргументы функции:

1) Исходная строка (а данном случае “AA”)

2) Число операций с исходной строкой

Значение первых 13 операций:

=replstr("AA";1) ABAB

=replstr("AA";2) AABAAB

=replstr("AA";3)

=replstr("AA";4) ABABABAB

=replstr("AA";5) AABAABAABAAB

=replstr("AA";6)

=replstr("AA";7) ABABABABABABABAB

=replstr("AA";8) AABAABAABAABAABAABAABAAB

=replstr("AA";9)

=replstr("AA";10)

=replstr("AA";11)

=replstr("AA";12)

=replstr("AA";13)

Для подсчета символов “A” в строке, используем еще одну функцию:

Function chrcount(str1 As String, str2 As String) As Integer

Dim str() As String

str = Split(str1, str2)

chrcount = UBound(str, 1)

End Function

Аргументы функции:

1) Cтрока

2) Символ (последовательность символов), число которых требуется найти

Например, результатом использования функции =chrcount(replstr("AA";20);"A") в ячейке Excel будет число 256

Используя описанные функции, посчитаем символы “A”в первых 13 строках

Номер операции (i) Число символов “A” в строке

1    2

2    4

3    4

4    4

5    8

6    8

7    8

8    16

9    16

10    16

11    32

12    32

13    32

Как видно из таблицы, число символов в строке образует числовую последовательность 2^1;  2^2; 2^2; 2^2; 2^3; 2^3; 2^3; … 2^([(i-2)/3]+2)

Таким образом, мы получили формулу для вычисления числа символов “A”в строке по номеру операции.

Соответственно, 2^([(43-2)/3]+2) = 32768

Пимкина Сергеевич

№1. Опишите фрагмент блок=схемы на языке программирования Паскаль. Укажите, какую задачу реализует данный алгоритм.

1) это алгоритм с разветвлением.

Описание: Если A ≤ B то, если правда, или: 1) х = А, или: 2) х = B (тут нет да/нет, на картинке).

Если требуется запись на языке Pascal:

Вариант 1)

var A, B, x: real;

begin

 readln(A); readln(B);

 if A <= B then x := A else x := B;

 writeln(x);

end.

Вариант 2)

var A, B, x: real;

begin

 readln(A); readln(B);

 if A <= B then x := B else x := A;

 writeln(x);

end.

2) это алгоритм циклический.

Описание: в начале задаются значения переменных: S = 0, k = 1. После: пока k ≤ 0 выполнять: S = S + k, k = k + 1.

Если требуется запись на языке Pascal:

var S, k: integer;

begin

 S := 0;  k := 1;

 while k <= 10 do begin

   S := S + k;  k := k + 1;

 end;

 writeln(S, ' ', k);

end.

№2. Определите количество и значения элементов массива, сформированного следующим образом:

а) для k = 0 до 5 делать: элементу массива присвоить значение, которое получается при делении нацело k на 3.

   k = 0, a[k] = 0;

   k = 1, a[k] = 0;

   k = 2, a[k] = 0;

   k = 3, a[k] = 1;

   k = 4, a[k] = 1;

   k = 5, a[k] = 1.

б) для k = 6 вниз 0 делать: элементу массива присвоить значение, которое получается при разница 5 и k.

   k = 6, a[k] = -1;

   k = 5, a[k] = 0;

   k = 4, a[k] = 1;

   k = 3, a[k] = 2;

   k = 2, a[k] = 3;

   k = 1, a[k] = 4;

   k = 0, a[k] = 5.

в) для k = 100 до 110 делать: если остаток от деления k на 3 не равен нулю, то элемент массива приравнять к сумме k и 2, иначе этот элемент станет равным 1.

   k = 100, a[k] = 102;

   k = 101, a[k] = 103;

   k = 102, a[k] = 1;

   k = 103, a[k] = 105;

   k = 104, a[k] = 106;

   k = 105, a[k] = 1;

   k = 106, a[k] = 108;

   k = 107, a[k] = 109;

   k = 108, a[k] = 1;

   k = 109, a[k] = 111;

   k = 110, a[k] = 112.

№3. Чему равна сумма элементов массива a[1] и a[6], сформированного следующим образом?

Формируется массив из 10 элементов. Первый элемент:

1 * 1 - 5 = -4

Шестой элемент: 6 * 6 - 5 = 31

31 + (-4) = 31 - 4 = 27 - это и ответ.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Дано число а заменить это число удвоенным произведением если оно нечетное. скок сижу не могу сделать program xz; var a: integer; begin; writeln ('введите число'); readln (a); if a mod 2=0 then writeln ('число четное') else a: =a*2; writeln ('удвоенное нечетное число'); readln; end. вот здесь где-то ошибка
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

tochkamail7
jagerlayf
Максим
Галина-Юлия1292
miss1380
fta1309
Назаренко1075
marinadetsad
Tamara
ooo-krasa
natanikulina1735
gsktae7
Umkatoys50
snabdonm501
Reginahappy