Ilin1022
?>

Заполните пропуски в программе, которая заполняет массив a[1..15]случайными числами в диапазоне от -10 до 10, выводит на экран исходный массив, затем преобразовывает его, прибавляя к четным элементам массива, а к нечетным - последний. первый и последний элементы не изменять. program preobrazovanie_2; var a: of ; i: integer; begin for i: = to do a[i]: =+; writeln('исходный массив: '); for i: = to do write(a[i], ' '); writeln; for i: = to do if a[i] then a[i]: = else a[i]: =; writeln('преобразованный массив: '); for i: = to do write(a[i], ' '); end.

Информатика

Ответы

northwest7745

program preobrazovanie_2;

var a:array[1..15] of integer;

i:integer;

begin

for i:= 1 to 15 do

a[i]:=random(21)-10;

writeln('Исходный массив:');

for i:= 1 to 15 do

write(a[i], ' ');

writeln;

for i:= 2 to 14 do

if a[i] mod 2 = 0

then a[i]:= a[i]+a[1]

else a[i]:=a[i]+a[15];

writeln('Преобразованный массив:');

for i:= 1 to 15 do

write(a[i], ' ');

end.

molchanovaelena284
Uses Crt;
  const n=5; m=7;
  type Mas = array [1..n, 1..m] of integer;
  var i, j, j1, j2: integer;
      Sumj1, Sumj2: real;
      A: Mas;
begin
 ClrScr;
 Randomize;
 SumJ1:=0; SumJ2:=0;
 for i:=1 to n do
    for j:=1 to m do
    A[i,j]:=random (10);
 WriteLn (' Massiv A: ');
 for i:=1 to n do
   begin
      for j:=1 to m do
      Write (A[i,j]:4);
      WriteLn;
   end; WriteLn;
 repeat
   Write (' Stolbez #1 = ');    ReadLn(j1);
 until (j1>=1) and (j1<=m);
 repeat
   Write (' Stolbez #2 = '); ReadLn(j2);
 until (j2>=1) and (j2<=m) and (j1<>j2);
 for i:= 1 to n do
    SumJ1 := SumJ1+A[i,j1];
 for i:= 1 to n do
   SumJ2:=SumJ2+A[i,j2];
 SumJ1:=SumJ1/n; SumJ2:=SumJ2/n; 
WriteLn;
WriteLn (' Srednee stolbza ', j1, ' = ', SumJ1:4:2);
WriteLn (' Srednee stolbza ', j2, ' = ', SumJ2:4:2); 
ReadLn;
end.
Паскаль.составить программу, вычисляющую среднее значение по двум столбцам матрицы. номера столбцов
ddavydov1116
Const nx=30;var i,j,p,n:integer;A:array[1..nx,1..nx] of integer;d,Sn,min:real;begin p:=1;write('Введите размер матрицы');Read(n);for i:=1 to n do beginfor j:=1 to n do beginA[i,j]:=random(3)-2;write(A[i,j]:4);end;writeln;end;writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif i = j then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);writeln;writeln;for i:=1 to n do beginfor j:=1 to n do beginif (i= n -j +1) then begin if A[i,j]<> 0 then p:=p* A[i,j];write(A[i,j]:4);endelse write(' ':4);end;writeln;end;write('p =',p);end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заполните пропуски в программе, которая заполняет массив a[1..15]случайными числами в диапазоне от -10 до 10, выводит на экран исходный массив, затем преобразовывает его, прибавляя к четным элементам массива, а к нечетным - последний. первый и последний элементы не изменять. program preobrazovanie_2; var a: of ; i: integer; begin for i: = to do a[i]: =+; writeln('исходный массив: '); for i: = to do write(a[i], ' '); writeln; for i: = to do if a[i] then a[i]: = else a[i]: =; writeln('преобразованный массив: '); for i: = to do write(a[i], ' '); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

artemiusst
Татьяна Марина1287
Fedorov1283
Nikolaevich-Svetlana388
suhanowaswetlana
АлександрАнатолий
Tsibrova
generallor3
petrowanastya202081
elizabetmaslova3
BrezhnevaKoidula
Mikhailovich_Viktoriya
Aleksandrovich_Mitoyan1138
laplena1982750
КараханянКусков
▲