Даниил247
?>

Решить с питон! задан массив x(n элементы с четными индексами переписать в массив z. в массиве z поменять местами максимальный и минимальный элементы.

Информатика

Ответы

Стефаниди

X=[15,1,0,255,12,38,154,36,794,2,54,-69]  #массив

Z=[]  #пустой массив

#запоминаем первый элемент из массива X как минимальный и максимальный

minc=X[0]

minind=0

maxc=X[0]

maxind=0

k=-1  #переменная-счетчик

for i in range(len(X)):  #цикл

   if i%2==0:

       k+=1

       Z.append(X[i])  #добавляем элемент Z[i], если i - четный

       print(Z)

# проверка на минимум и максимум

       if X[i]>maxc:

           maxc,maxind=X[i],k

       if X[i]<minc:

           minc,minind=X[i],k

   print(minind,maxind,k)

Z[minind]=maxc

Z[maxind]=minc

print(Z)

almihanika435
Вариант 1
var  str:string;
  A,B,i:integer;
 begin
   write('введите ваш текст');
   readln(str);
   for i:=1 to length(str) do begin
     if (str[i]='А')or (str[i]='а') then a:=a+1;
     if (str[i]='Б')or (str[i]='б') then B:=b+1;
   end;
   if (A+B)=0 then write('нет таких букв') else write ('A= ',A,' Б= ',b);
end.

вариант 3
var  str:string;
  A,B,i:integer;
 begin
   write('введите ваш текст');
   readln(str);
   i:=1;
   while i<=length(str) do begin
    if (str[i]='А')or (str[i]='а') then delete(str,i,1);
    i:=i+1;
    end;
   write(str);
      end.
vtarasyuk
Всем тем, кому не понятен язык, 2. циклы 1. найти наименьший делитель натурального числа 2. найти все делители натурального числа 3. найти наибольший делитель натурального числа 4. найти сумму делителей числа 600 и их количество 5. найти все делители чисел 90 и 360 6. найти натуральное число, произведение всех делителей которого =5832 7. найти натуральное число, если оно делится на 3 и 4 и имеет 14 делителей 8. подсчитать количество делителей натурального числа, сформированное гениратором случайных чисел в диапазоне от 1 др 10000 9. составить проагрмму, которая нашла бы в интервале от 1 до 1000 число, с наибольшим количеством делителей 10. найти натуральное число в пределах о 1 до 10000 с максимальной суммой делителей 11. составить программу, которая бы напечатала бы все простые числав диапазоне от n до m, а также подсчитать их количество. n и m ввести с клавиатуры 12. между любыми двумя последовательными простыми числами находится заданное число к ? 13. найти и вывести на экран 5 простых чисел, больших заданного к, вводится с клавиатуры. 14. дано простое число р. найти следущее простое число 15. задано некоторое натуральное число р. найти ближайшее к нему простое число. 16. найти все трехзначные числа , кратные 7, сумма цифр которых также кратно 7. если найденное число нечетное , определить , является ли оно простым 17. составить программу поиска трех простых чисел, предшествующих числу м , вводимый с клавиатуры ( м > = 10). 18. составить программу поиска всех цифр - близнецов, принадлежащих заданному диапазону [m , n] . 19. дано простое число. есть ли у него число - близнец ? 20. определить, является числа находящихся по обе стороны от заданного четного числа с , близнецами . 21. является ли заданное натуральное число совершенным ? 22. составить программу поиска всех пар дружественных чисел , меньших 10000 . 23. определить количество разрядов натурального числа n, заданного пользователем . 24. вычислить сумму цифр натурального числа n. 25. записать заданное число n в обратном порядке. 26. составить программу , которая проверяет , является ли число n, вводимое с клавиатуры , палиндромом . 27. найти и напечатать все натуральные числа , которые при возведении в квадрат палиндром . 28. составить программу , которая проверяет , есть ли среди палиндромов в интервале [ 10..1000000 ] простые числа. 29. составить программу , печатающую все нечетные палиндромы в интервале [ 10..1000000 ] . 30. найти и напечатать все натуральные числа в интервале [ 1..2000 ] , равные сумме кубов своих цифр . 31. найти и напечатать все натуральные числа в интервале [ 1..5000 ], равные кубу суммы своих цифр . 32. найти и напечатать все четырехзначные числа , у которых сумма первых двух цифр равна сумме двух последних . 33. в заданном натуральном числе выбросить цифры 3 и 7, оставив неизменным порядок других цифр . 34. проанализировать все числа из диапазона [ 10..1000 ] и напечатать те из них , в записи которых нет цифр 3 и 7 . 35. найти количество шестизначных чисел, у которых все цифры разные. 36. на интервале от n до k выбрать те числа ,которые содержат ровно 3 одинаковые цифры . пример : 6766 , 5444 , 0060 , 0006 . 37. составить программу вычисления цифрового корня натурального числа , введенного с клавиатуры. вычислить и напечатать цифровые корни совершенных чисел, принадлежащих диапазону от х до у, вводящихся с клавиатуры 38. вычислить и напечатать все числа в диапазоне [ 10..9999 ] , кратные своему цифровому корню . 39. вычислить и напечатать все числа в диапазоне [ 100..99999 ], цифровой корень которых: кратный 3 или 5 является простым числом 40. задано 3 натуральных числа. найти нод наибольшего и наименьшего из них. 41. сколько существует натуральных чисел от 20 до 120 , а не взаимно простых с 30 ? 42. сколько существует натуральных чисел, меньших 100 и взаимно простых с числом 36 ? 43. найти все натуральные числа , меньше заданного натурального м и взаимно простые с ним. 44. составить программу сокращения дробей . 45. сравнить две дроби по величине . 46. ​​составить программу сложения ( вычитания ) двух дробей . 47. составить программу умножения ( деления ) двух дробей .

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Решить с питон! задан массив x(n элементы с четными индексами переписать в массив z. в массиве z поменять местами максимальный и минимальный элементы.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

proplenkusale88
info40
buriginast5
Salko17
mvinogradov6
Shelchkowa453
misspodvigina
Arutyunovich
Yuliya701
alexseyzyablov
lepekhov4011
Romanovich1658
Kozloff-ra20146795
yuraotradnov
Татьяна