hotel-info
?>

Составить программу вычисления, a - сумма положительных элементов массива; b - количество отрицательных элементов массива; c - произведение элементов массива с нечетными номерами. полученные значения элементов а, b, c, w вывести на печать. паскаль!

Информатика

Ответы

Olesya-elena1525

const n=10;

var m:array [1..n] of integer;

i,A,B,C:integer;

begin

C:=1;

write('Массив: ');

for i:=1 to n do

begin

m[i]:=random(41)-20;

if m[i] > 0 then A:=A+m[i];

if m[i] < 0 then B:=B+1;

if i mod 2 <> 0 then C:=C*m[i];

write(m[i],'  ')

end;

writeln;

writeln('Сумма положительных элементов: ',A);

writeln('Количество отрицательных элементов: ',B);

writeln('Произведение элементов массива с нечетными номерами: ',C);

end.

grafffmc

1) 

var a:array [1..100] of integer;

n,i:integer;

begin

for i:=10 to 99 do begin

a[i]:=i;

if (a[i] mod n=0) then writeln(a[i]);

end;

end.

 

 2)

var a:array [1..100] of integer;

n,k,i,x,y,z: integer;

begin

readln(n,k);

for i:=n to k do begin

a[i]:=i;

x:=a[i] mod 10;

y:=a[i] div 10;

z:=y mod 10;

y:=y div 10;

if (x=y) or (x=z) or (y=z) then writeln(a[i]);

end;

end.

 

 3)

 var a,n,an,na: integer;

begin

readln(a,n);

if (a>0) and (b>0) then begin

an:=a*10+n;

na:=n*10+a else writeln('Введены неверные числа!');

end;

end.

Викторович Попков
Разница в объеме хранимой информации, сходство с записиСходства-одинаковые размеры (диаметр 120 мм, толщина 1.6 мм), тот же радужный вид. Принцип записи и чтения тоже аналогичный: лазерный луч отражается от металлизированной поверхности ("ямок" и "горок"), причем, отражение от любой поверхности кодирует ноль, а отражение от перехода между ямкой и горкой (при этом луч ослабляется за счет интерференции) - единицу 
На этом сходство заканчивается - дело в том, что в CD используется инфракрасный лазер (длина волны в воздухе 780 нм). В DVD же применяется красный лазер (650/635 нм). Меньшая длина волны позволяет плотнее размещать информацию на DVD-диске. 
Ёмкость DVD сильно превосходит обычный компакт-диск (640 Мб) и составляет 4.38 гигабайта (в смысле 2^30 байт) или 4.7 миллиарда байт, имеется в виду односторонний, однослойный DVD-диск

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления, a - сумма положительных элементов массива; b - количество отрицательных элементов массива; c - произведение элементов массива с нечетными номерами. полученные значения элементов а, b, c, w вывести на печать. паскаль!
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

yanermarina87
Марина1101
natalia-shelkovich
andreanikin
Natalya1895
sveta740450
corneewa20096
Ионов202
sryzhova6392
ЮлияДаниил520
seleznev1980
Rafigovich1267
alenchik19938823
Александровна
serge-lysoff