SaraevaTretyakov1941
?>

Pascal abc составьте программу, которая определяет на какую букву заканчивается третье слово в предложении.

Информатика

Ответы

Zladthesecond577
Var a: string;
b,c: integer;
begin
readln (a)
While c<3 do
begin
b :=b+1;
if (a[b] = (" ")) or a[b] = (" , "))
then c:=c+1;
end;
writeln (a[b-1]);
end.
Стуканова УЧРЕЖДЕНИЕ1877

Задачки такого типа не имеют однозначного решения, можно предложить нескольео вариантов и все они будут правильные. Слишком мало членов дано.

Вот мои версии.

 

а. 1; 3; 6; 4; 11; 5; 16; 6 (на нечётных местах всё время +5, на чётных +1)

 

б. 9; 7; 10; 4; 11; 1; 12; -2; ... (на нечётных +1, на чётных -3)

 

в. 3; 2; 1; 6; 5; 4; 9; 8; 7; 12; 11; 10... (тройки n;n-1;n-2; первое число тройки - последовательные числа, кратные 3)

 

Могу предложить ещё несколько ДРУГИХ вариантов продолжения последовательностей и все они, повторюсь, будут ПРАВИЛЬНЫМИ. 

Одно только замечание: ВСЕГДА нужно указывать алгоритм или формулу, по которой последовательность строится(продолжается).

 

urazmetova

Задачки такого типа не имеют однозначного решения, можно предложить нескольео вариантов и все они будут правильные. Слишком мало членов дано.

Вот мои версии.

 

а. 1; 3; 6; 4; 11; 5; 16; 6 (на нечётных местах всё время +5, на чётных +1)

 

б. 9; 7; 10; 4; 11; 1; 12; -2; ... (на нечётных +1, на чётных -3)

 

в. 3; 2; 1; 6; 5; 4; 9; 8; 7; 12; 11; 10... (тройки n;n-1;n-2; первое число тройки - последовательные числа, кратные 3)

 

Могу предложить ещё несколько ДРУГИХ вариантов продолжения последовательностей и все они, повторюсь, будут ПРАВИЛЬНЫМИ. 

Одно только замечание: ВСЕГДА нужно указывать алгоритм или формулу, по которой последовательность строится(продолжается).

 

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Pascal abc составьте программу, которая определяет на какую букву заканчивается третье слово в предложении.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

d43irina
ilyxa08
svetkaiv
ivanda
Svetlana191
almihanika435
sapelnikovk-74
смирнов1127
впвыпвып-Зуйков629
nusupova
Artur-62838
shtankosoyuz1629
lazu8375
Burov1446
natalyazx151092814
▲