dddandmvd5210
?>

Заполните массива [1..10] случайными целыми числами в диапазоне от -20 до 20 и найдите сумму максимального и минимального элементов данного массива.

Информатика

Ответы

gorsimonyan4

program fantscrin;


 const n = 10;


 var a: array [1..n] of integer;


     i,min,max:integer;


Begin


 for i:=1 to n do


   a[i]:= random(41)-20;


 for i:=1 to n do


   write(a[i], '  ');


   


 min:=a[1];


 for i:=1 to n do


   if (a[i]<min) then min:=a[i];


 


 max:=a[1];


 for i:=1 to n do


   if (a[i]>max) then max:=a[i];


 


   


 writeln('');


 writeln(min+max);


End.

Мусаев Игоревич371

1. Линейным называется алгоритм, в котором команды выполняются в порядке их записи.

2. Утром надо встать, почистить зубы, застелить кровать, одеться и позавтракать, а потом идти в школу

3. Ветвление - это выполнение той или другой последовательности действий в зависимости от выполнения какого-либо условия

4. пример из жизни: если сделал уроки,то отдыхай,иначе делай уроки.

и ещё пример: если натуральное число делится на два без остатка,то данное число чётное,иначе данное число нечётное

5. Русский богатырь около путевого камня: Направо пойдёшь - коня потеряешь, налево пойдёшь - жизнь потеряешь, прямо пойдёшь - жену найдёшь и. т. д. (Иван царевич и серый волк, Алеша попович)

золушка вот решила на бал пойти: )

Русалочка решила ноги себе сделать) )

Колобок решил из дома укатиться) )

козлята открыли двери волку.

Царевич целует лягушку.

6. Циклическим называется алгоритм, в котором повторяется выполнение одной и той же последовательности команд.

7.

1)Сказать(Купи слона!)

2)Выслушать ответ.

3)Сказать(Все говорят:)

4)Сказать то, что ответил собеседник

5)сказать(,а ты возьми и купи слона!)

6)вернуться к пункту 2:

plv-57
1. В системное программное обеспечение входят:
A) языки программирования (язык — не программа);
✔ операционные системы;
C) совокупность программ и устройств общего назначения (это ПО);
D) игры (это прикладное ПО);

2. Путь к файлу- это….
A) поименованная область на диске (это файл);
B) часть ОС, определяющая организации, хранения и именования файлов на носителях информации (это файловая система).
C) список имён каталогов, собранных в корневом каталоге;
✔ последовательность из имён каталогов, разделённых знаком «\»;

3. Отметьте правильную запись имени текстового файла?
A) basa-com;
✔ basa.txt (имя.расширение, txt — расширение текстовых файлов); 
C) :basa.txt;
D) BASA.SYS;

4. Какое расширение имеют исполняемые файлы?
A) docx, txt (word, текст)
✔ com, exe
C) txt, sys (текст, что-то системное)
D) sys, com (что-то системное, исполняемый)

5. Как называется наука об общих закономерностях получения, хранения, преобразования информации в сложных управляющих системах (например, машины, живые организмы, общество).
A) информатика
B) физика 
✔ кибернетика 
D) история 

6. Кто в 1950 году написал статью «Может ли машина мыслить»?
A) Винер
B) Колмогоров 
✔ Алан Тьюринг 
D) Ампер

7. Кто в 1946 году предложил теорию решения изобретательских задач (изучение проблем технического творчества систем искусственного интеллекта)?
✔ Альтшуллер
B) Полетаев 
C) Ломоносов 
D) Колмогоров 

8. Электронная таблица предназначена для:
✔ обработки преимущественно числовых данных, структурированных с таблиц; 
B) упорядоченного хранения и обработки значительных массивов данных; 
C) визуализации структурных связей между данными, представленными в таблицах; 
D) редактирования графических представлений больших объемов информации. 

9. В электронной таблице основной элемент рабочего листа – это:
✔ ячейка;
B) строка;
C) столбец;
D) формула.

10. Выберите верный адрес ячейки в электронной таблице:
A) 11D;
✔ F12 (последовательность латинских букв, потом номер строки);
C) AБ-3;
D) B1A. 

11 Выражение 5(A2+C3):3(2B2-3D3) в электронной таблице имеет вид:
A) 5(A2+C3)/3(2B2-3D3) ; 
B) 5*(A2+C3)/3*(2*B2-3*D3) ; 
✔ 5*(A2+C3)/(3*(2*B2-3*D3)) ; 
D) 5(A2+C3)/(3(2B2-3D3)) . 

12. Чему будет равно значение ячейки С1, если в нее ввести формулу =СУММ(A1:A7)/2:
Нет приложения

13. Первая позиционная система счисления была придумана:
✔ в древнем Вавилоне (шестидесятиричная);
B) в древней Индии;
C) в древнем Китае;
D) в древнем Египте.

14. Число, записанное в римской системе счисления CDXIV, равно: 
A) 1595;
✔ 414 (что-то... IV должно оканчиваться на 4);
C) 595;
D) 692.

15. Выберите правильную запись числа в десятичной системе счисления 63910 в развернутой форме:
✔ 6∙104+3∙103+9∙102+1*101
B) 6∙103+3∙102+9∙101+1*100 
C) 9∙102+3∙101+6∙100
D) 600+30+9

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Заполните массива [1..10] случайными целыми числами в диапазоне от -20 до 20 и найдите сумму максимального и минимального элементов данного массива.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Мирзоев Денис
Dmitrievna405
firsova5911
Sokolova-Shcherbakov
astahova
office3
postbox
dima-a
pbttehnology
Банова_Елена431
озерская_Мария1234
guujuu
eronch
Шавкат кызы
Vgubushkin