gernovoy
?>

Втроичной машине поста дан массив меток из 0 и 1 – число в дво- ичном виде. необходимо составить программу, которая увеличивала бы задан- ное число на 1. начальное и конечные положения каретки – первый символ слова.

Информатика

Ответы

Шиморянов Мария1866

1. На ленте машины Тьюринга содержится последовательностью символов “+”. Напишите программу для машины Тьюринга, которая каждый второй символ “+” заменит на “–”. Замена начинается с правого конца последовательности. Автомат в состоянии q1 обозревает один из символов указанной последовательности. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

2. Дано число n в восьмеричной системе счисления. Разработать машину Тьюринга, которая увеличивала бы заданное число n на 1. Автомат в состоянии q1 обозревает некую цифру входного слова. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

3. Дана десятичная запись натурального числа n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

4. Дано натуральное число n > 1. Разработать машину Тьюринга, которая уменьшала бы заданное число n на 1, при этом в выходном слове старшая цифра не должна быть 0. Например, если входным словом было “100”, то выходным словом должно быть “99”, а не “099”. Автомат в состоянии q1 обозревает правую цифру числа. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

5. Дан массив из открывающих и закрывающих скобок. Построить машину Тьюринга, которая удаляла бы пары взаимных скобок, т.е. расположенных подряд “( )”.

Например, дано “) ( ( ) ( ( )”, надо получить “) . . . ( ( ”.

Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

6. Дана строка из букв “a” и “b”. Разработать машину Тьюринга, которая переместит все буквы “a” в левую, а буквы “b” — в правую части строки. Автомат в состоянии q1 обозревает крайний левый символ строки. Кроме самой программы-таблицы, описать словами, что выполняется машиной в каждом состоянии.

margarita25061961
Суждение:
1. Все сосны являются деревьями.
2.Ни один кит - не рыба.
3.Все караси являются рыбами.
4. Все розы - это цветы.
5. Все мухи - это птицы.

Умозаключения:
1. Ты задал вопрос, вопрос задают когда не знают. Умозаключение: ты не знаешь.
2. Все прямоугольники-параллелограммы. Квадрат - это прямоугольник. Умозаключение: квадрат - это параллелограмм.
3. Все люди смертны. Сократ - человек. Умозаключение: Сократ смертен.
4. Звезды взрываются. Солнце - звезда. Умозаключение: Солнце взорвется.
5. У треугольника все углы равны. Умозаключение: треугольник равноугольный
pastore
Возможный вариант в C++
#include <iostream>
int main()
{
    using namespace std;
    int N;
    cout << "Enter N: ";
    cin >> N;
    int num;
    int max = 1;
    int i;
    for (i = 0; i < N; ++i)
    {
        cout << "Enter #" << i + 1 << " number: ";
        cin >> num;
        if ((num - 9) % 10 != 0 && num % 3 == 0)
        {
            max = num;
            break;
        }
    }
    for (int j = i + 1; j < N; ++j)
    {
        cout << "Enter #" << j + 1 << " number: ";
        cin >> num;
        if ((num - 9) % 10 != 0 && num % 3 == 0)
            if (num > max)
                max = num;
    }
    if (max != 1)
        cout << "Max number div by 3 and don't end 9: " << max << endl;
    else
        cout << "No numbers div by 3 and don't end 9" << endl;
    return 0;
}

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Втроичной машине поста дан массив меток из 0 и 1 – число в дво- ичном виде. необходимо составить программу, которая увеличивала бы задан- ное число на 1. начальное и конечные положения каретки – первый символ слова.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

olgaprevisokova302
ИП-Сысоев1628
Vasileva
palmhold578
turovskaya69
tatiyanabe2013727
ОвсепянСергей88
osirparts7854
s45983765471717
mv7095
stusha78938
allo22-27
tofilev
tatiana2676
laktionova-natal