Паскаль. написать программу разветвляющегося алгоритма решения ниже данной на языке pascal : даны два целых числа: a, b. проверить истинность высказывания: «справедливы неравенства a > 1 и b < – 3».
Каждый раз с приходом зимы и выпадением снега мы переживаем какой-то эмоциональный всплеск. Белое покрывало, накрывшее город, дремучие леса и перелески, бескрайние поля и широкие реки и укутавшее деревья в причудливо мерцающие на солнце одежды, не оставит равнодушным ни ребенка, ни взрослого. В детстве мы могли часами сидеть у окна и наблюдать за тем, как, медленно кружась, пролетают мимо снежинки и тихо опускаются на землю... Мы часто рассматривали их структуру, пытаясь найти две одинаковые, не переставая удивляться красоте и сложности этого волшебного великолепия. - Читайте подробнее на FB.ru: http://fb.ru/article/138402/chto-takoe-sneg-otkuda-beretsya-i-iz-chego-sostoit-sneg
mayskiyandrey90
28.10.2022
Фабрика снега
Откуда берутся снежинки? Ребенок сам даст ответ: из облаков. А вот что происходит в этих «фабриках снега»? Облако, как все знают, этот просто скопления великого множества микроскопических капелек воды. Есть там и частицы пыли. Капли притягиваются к ним и примерзают в виде крохотных иголочек льда.
Этот кристаллик больше обычной капли и потому тяжелее. Из-за этого он выпадает из облака и летит вниз. Но ведь по пути, в воздухе тоже есть частицы влаги. И на падающем кристалле оседают новые иголочки. Они отрастают в стороны от кончиков кристалла. Пока снежинка долетит до земли, она становится красивой ветвистой звездочкой.
На пути к земле
В пути, пролетая через более теплые слои воздуха, они могут подтаивать, а потом снова нарастать. Форма кристалла зависит и от давления воздуха, ветра, от столкновений друг с другом. Часто несколько снежинок в пути слипаются или, наоборот, разламываются. Не будем углубляться в физику. Поверьте на слово ученым: двух совершенно одинаковых снежинок не бывает.
Если у вас дома есть хотя бы небольшая лупа, рассмотрите с ребенком снежинки, упавшие на варежку. Форма их может быть очень разной: пластинки с лучами на концах, 12- лучевые звезды, столбики с коронами, ежики, бокалы на ножках. В коллекциях специалистов – тысячи фотографий снежинок разной формы. В Японии есть даже музей снежинок. Замечательными фотогалереями снежинок вы можете полюбоваться на сайте SnowCrystals.com.
Осторожно – снежинка!
Обычно снежинка не больше клеточки в школьной тетради и очень легкая – 250 снежинок весит всего один грамм. Но и здесь есть свои рекорды: самую большую снежинку обнаружили в штате Монтана (США) в январе 1887 года. Вы не поверите – она была размером побольше стандартного листа А4! В 1944 г. в Москве выпадали снежные хлопья размером с блюдце.
Осталось несколько вопросов попроще. Почему снег скрипит, если по нему едешь на санках, или хрустит, когда просто идешь или лепишь снежки? Это шум от того, что ломаются и трутся друг о друга тысячи крошечных кристалликов льда. А отчего снежинки и снег – белого цвета? Его придают крошечные пузырьки воздуха, которые вмерзли в кристаллы.
Почему снег становится твердым, когда полежит? Солнце плавит верхний слой пушистого снега, превращая его в воду. А холодный воздух замораживает его снова. Такая корка на снегу называется настом.
Конечно, твердый наст не такой красивый и приятный, как пушистый снежок. Снежинок не разглядишь, снеговиков не полепишь. Но зато он говорит нам: «Тепло ушло ненадолго! Весна не за горами!»
Program programm;
var A,B: integer;
begin
writeln('Введите число A: ');
readln(A);
writeln('Введите число B: ');
readln(B);
if (A > 1) and (B < -3) then
writeln('Неравенство ВЫПОЛНЕНО!')
else
writeln('Неравенствено НЕ выполненно!');
end.