ivanovmk1977
?>

Составить программу вычисления значения функций y= x^3-2, 5xy+1, 78x^2-12, 5y. при любых значениях (x) и (y) (pascal)

Информатика

Ответы

zaravshan20134
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  Writeln('*** Исходный массив ***');
  var a:=MatrRandom(5,5,-5,14);
  a.Println(4); Writeln(4*a.ColCount*'-');
  a.SwapCols(0,1);
  Writeln('*** Результирующий массив ***');
  a.Println(4);
end.

Пример
*** Исходный массив ***
  12  10   7  -2   5
  14   0   7   1  14
   0  -1   7   5   7
  -5  -5  -4  -4   9
   7   8  -5  12  12

*** Результирующий массив ***
  10  12   7  -2   5
   0  14   7   1  14
  -1   0   7   5   7
  -5  -5  -4  -4   9
   8   7  -5  12  12
avolodyaev

Если вы часто работаете в MS Word, сохранение документа в качестве шаблона наверняка вас заинтересует. Так, наличие шаблонного файла, с установленным вами форматированием, полями и прочими параметрами, может во многом упростить и ускорить рабочий процесс. 

Шаблон, создаваемый в ворде, сохраняется в форматах DOT, DOTX или DOTM. Последний разрешает работу с макросами. Шаблон — это особый тип документа, при его открытии и последующем изменении создается копия файла. Исходный (шаблонный) документ при этом остается неизменным, как и его местоположение на диске. В качестве примера того, каким может быть шаблон документа и зачем вообще он нужен, можно привести бизнес-план. Документы этого типа довольно часто создаются в Word, следовательно, используют их тоже довольно часто.

Так, вместо того, чтобы каждый раз заново создавать структуру документа, выбирать подходящие шрифты, стили оформления, устанавливать размеры полей, можно просто использовать шаблон со стандартным макетом. Согласитесь, такой подход к работе куда более рационален. Документ, сохраненный в качестве шаблона, можно открыть и заполнить необходимыми данными, текстом. При этом, сохраняя его в стандартных для Word форматах DOC и DOCX, исходный документ (созданный шаблон), будет оставаться неизменным, как уже было сказано выше.

Создание собственного шаблона

Проще всего будет начать создание шаблона с пустого документа, для открытия которого достаточно просто запустить Word.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Составить программу вычисления значения функций y= x^3-2, 5xy+1, 78x^2-12, 5y. при любых значениях (x) и (y) (pascal)
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Petrovich
katyn76
Panfilov_Anna
Andreevich
alekseymedvedev1981
TatyanaVladimirovich
Alekseevich_Elena
eisakov86
Vyacheslav_Nikolaevna
abcd138191
ak74-81
format-l3364
Рафаэль633
lugowskayatania2017
puchkovajulia
▲