//Задача 1
begin
var a := ArrRandom(20, -20, 20).Println;
Println(a.Min, ' ', a.Max);
end.
//Задача 2
begin
var a := ReadArrInteger(10);
a.Where(p -> p.IsOdd).Count.Println;
end.
//Задача 3
begin
SeqGen(90, 10, x -> x + 1).Where(x -> x mod 3 = 0).Println;
end.
//Задача 4
begin
ArrRandom(10,-20,20).Println;
end.
//Задача 5
begin
var (a, b) := ReadInteger2;
Range(a, b).Product.Println
end.
//Задача 4
var
n, i, sum, count: integer;
begin
Writeln('Введите число: ');
Readln(n);
count := 0;
while n <> 0 do
begin
i := n mod 10;
sum += i;
count += 1;
n := n div 10;
end;
Writeln('Сумма цифр: ', sum);
Writeln('Количество: ', count);
end.
//Задача 7
var
n, i, sum, count: integer;
begin
Writeln('Введите число: ');
Readln(n);
count := 0;
while n <> 0 do
begin
i := n mod 10;
if not Odd(i) then count += 1;
n := n div 10;
end;
if count <> 0 then Writeln('True')
else Writeln('False');
end.
Задача 8
begin
var n := ReadInteger;
for var i := 1 to n do
begin
Println('Я НЕ учусь программировать');
end;
end.
Поделитесь своими знаниями, ответьте на вопрос:
Составить программу и блок схему на листе. для : , , найдите наибольшее из 3 чисел а, в, с"
//Задача 1
begin
var a := ArrRandom(20, -20, 20).Println;
Println(a.Min, ' ', a.Max);
end.
//Задача 2
begin
var a := ReadArrInteger(10);
a.Where(p -> p.IsOdd).Count.Println;
end.
//Задача 3
begin
SeqGen(90, 10, x -> x + 1).Where(x -> x mod 3 = 0).Println;
end.
//Задача 4
begin
ArrRandom(10,-20,20).Println;
end.
//Задача 5
begin
var (a, b) := ReadInteger2;
Range(a, b).Product.Println
end.
//Задача 4
var
n, i, sum, count: integer;
begin
Writeln('Введите число: ');
Readln(n);
count := 0;
while n <> 0 do
begin
i := n mod 10;
sum += i;
count += 1;
n := n div 10;
end;
Writeln('Сумма цифр: ', sum);
Writeln('Количество: ', count);
end.
//Задача 7
var
n, i, sum, count: integer;
begin
Writeln('Введите число: ');
Readln(n);
count := 0;
while n <> 0 do
begin
i := n mod 10;
if not Odd(i) then count += 1;
n := n div 10;
end;
if count <> 0 then Writeln('True')
else Writeln('False');
end.
Задача 8
begin
var n := ReadInteger;
for var i := 1 to n do
begin
Println('Я НЕ учусь программировать');
end;
end.