migor72
?>

1. поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. напишите программу, которая по введенным координатам двух полей (k, l) и (m, n) определяет, являются ли эти поля полями одного цвета. пример входных данных: координаты 1-го поля - 2 2; координаты 2-го поля - 3 3 пример выходных данных: поля одного цвета 2.напишите программу, в которой пользователю предлагается дополнить до 100 некоторое целое число а (а - случайное число, меньшее 100 ответ пользователя проверяется и комментируется.

Информатика

Ответы

boldyrevanastia22
1. var k, l, m, n: integer; begin     readln(k,l,m,n);     if (k+l+m+n mod 2 = 0) then     writeln('поля одного цвета')   else     writeln('поля разных цветов') end. 2. uses crt; {в зависимости от компилятора эта строчка может оказаться лишней} var question, answer: integer; begin   randomize();   question : = random(100);   writeln(question);   readln(answer);   if (question+answer=100) then     writeln('not bad')   else     writeln('oops. right answer is ', 100-question) end.
Надежда-Алексеевна82
// pascalabc.net 3.3, сборка 1540 от 16.09.2017 // внимание! если программа не работает, обновите версию! begin   var n: =readinteger('n=');   var a: =arrrandom(n,-35,35); a.println;   var (k1,k3): =readinteger2('введите границы индексов для замены элементов: ');   // блок "защиты от дурака"   if k1< 1 then k1: =1;   if k1> n-1 then k1: =n-1;   if k3< 1 then k3: =1;   if k3> n-1 then k3: =n-1;   if k1> k3 then swap(k1,k3);   //   for var i: =k1-1 to k3-1 do a[i]: =-a[i];   a.println end. пример n= 13 -27 18 15 31 27 -1 -5 20 -20 -34 -7 -33 16 введите границы индексов для замены элементов: 6 9 -27 18 15 31 27 1 5 -20 20 -34 -7 -33 16
Дмитрий_Владимирович1162
// pascalabc.net 3.3, сборка 1540 от 16.09.2017 // внимание! если программа не работает, обновите версию! begin   var x: =-5.0;   writeln('  x            x*x');   repeat       writeln(x: 4: 1,x*x: 10: 2);       x+=0.5   until x> 5 end. результат   x            x*x -5.0        25.00 -4.5        20.25 -4.0        16.00 -3.5        12.25 -3.0          9.00 -2.5          6.25 -2.0          4.00 -1.5          2.25 -1.0          1.00 -0.5          0.25   0.0          0.00   0.5          0.25   1.0          1.00   1.5          2.25   2.0          4.00   2.5          6.25   3.0          9.00   3.5        12.25   4.0        16.00   4.5        20.25   5.0        25.00

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

1. поле шахматной доски определяется парой натуральных чисел, каждое из которых не превосходит 8. напишите программу, которая по введенным координатам двух полей (k, l) и (m, n) определяет, являются ли эти поля полями одного цвета. пример входных данных: координаты 1-го поля - 2 2; координаты 2-го поля - 3 3 пример выходных данных: поля одного цвета 2.напишите программу, в которой пользователю предлагается дополнить до 100 некоторое целое число а (а - случайное число, меньшее 100 ответ пользователя проверяется и комментируется.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Новицкий1107
bksenia9775
vladburakoff5
eugene869154
Tsibrova
yastrik
natasham-716
mir5552
lokos201272
vladusha47713
maksmi
zubareva23338
Plyushchik_Nikita
Виктор-Богданов
almihanika435