program raf105;
var n,m,i:integer;
begin
writeln('Введите диапазон чисел (2 числа через пробел) которые нужно возвести в квадрат');
readln(n,m);
writeln('Вывод:');
for i:=n to m do
writeln(i**2)
end.
2.program raf105;
var a,b,kol1,kol2:integer;
begin
write('Введите число: ');
readln(a);
while a <> 0 do
begin
b:= a mod 10;
if b<>0
then if (b mod 2)=0
then kol1+= 1
else kol2+= 1;
a:= a div 10;
end;
writeln('В числе ',kol1,' чётных и ',kol2,' нечётных цифр');
end.
3.program raf105;
var n,i,kol:integer;
begin
write('Введите N: ');
readln(n);
for i:=1 to n-1 do
if ((i mod 2)<>0) and ((i mod 3)<>0) and ((i mod 5)<>0)
then kol+=1;
writeln('Вывод: ',kol);
end.
Язык PascalABC
Поделитесь своими знаниями, ответьте на вопрос:
Нужно составить программу на паскале (через задан список студентов из 7 фамилий. распечатать данный список в столбец и найдите в списке все фамилии, начинающиеся со слога «ма».
var n:integer;
begin
n:=301;
while n mod 19<>0 do n:=n+1;
writeln(n,' / 19 = ',n div 19);
end.
Пример:
304 / 19 = 16
2)
var n,c,k1,k2,s,k3:integer;
begin
write('n = ');
readln(n);
k1:=0; k2:=0; s:=0; k3:=0;
while n > 0 do
begin
c:=n mod 10;
if c mod 2=0 then k1:=k1+1 else k2:=k2+1;
s:=s+c;
if c mod 3=0 then k3:=k3+1;
n:= n div 10;
end;
writeln('количество цифр числа = ',k1+k2);
writeln('их сумма = ',s);
writeln('количество четных цифр = ',k1);
writeln('количество нечетных цифр = ',k2);
writeln('количество цифр, кратных 3 = ',k3);
end.
Пример:
n = 2745194
количество цифр числа = 7
их сумма = 32
количество четных цифр = 3
количество нечетных цифр = 4
количество цифр, кратных 3 = 1