хаджимурод1172
?>

Напишите программу определяющую является ли заданное целое положительное число простым паскаль 7 класс

Информатика

Ответы

elyashatdinova
Or - "ИЛИ". Если одно из условий верно, то и все выражение принимает истину [ 0 or 1 = 1 ; 1 or 0 = 1; 1 or 1 = 0, 0 or 0 = 0], где 1 - истина, а 0 - ложь
у тебя условие 
If(k>9) or (k<14) then
условие k > 9 выполняется, а значит и все выражение верно
Нужно заменить "OR" на "AND" оператор "И". 
[ 1 and 1 = 1 ] при всех остальных - ложь

Вот код

var
k: integer;
begin
 readln(k);
  if k > 17 then
    Writeln('ваша оценка 5. Молодец!');
  if (k > 13) and (k < 18) then 
    Writeln('ваша оценка 4.'); 
if(k > 9) and (k < 14) then 
    Writeln('ваша оценка 3.'); 
if k < 10 then
    Writeln('ваша оценка 2.');
end.
evrotrastop64
№1.
Тысячи путей ведут к заблуждению, к истине - только один.
Для начала надо посчитать, сколько всего символов в данном предложении, следует считать знаки препинания и пробелы. 
Посчитав все знаки (Итого:57), мы получаем, что вес предложения 57 байт, переводим в биты, то есть умножаем на 8 (1 байт = 8 бит):
57*8=456.

№2.
Кодировка Unicode - это кодировка, каждый символ которой весит 16 бит. Итак, я посчитала количество знаков в предложении (Итого:32). Дальше: 16*32=512 бит.

№3.
Итак, мы видим, что из 16-битной кодировки получилась 8-битная, а это значит, что она уменьшилась вдвое.
8x=800
x=100 (у тебя ошибка, я посмотрела аналогичные задания, отличающиеся только значениями)

№4 допишу в комментарии.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Напишите программу определяющую является ли заданное целое положительное число простым паскаль 7 класс
Ваше имя (никнейм)*
Email*
Комментарий*