olesyadeinega41
?>

Определите, количество чисел k, для которых следующая программа выведет такой же результат, что и для k = 12? var k, i : longint; function f(n: longint): longint; begin f: = 3*n*n - 2*n; end; begin readln(k); i : = 1; while f(i) < k do i : = i + 1; if f(i)-k < = f(i-1) then writeln(i) else writeln(i-1); end.

Информатика

Ответы

italiankarest

Цей електронний підручник знайомить з мовою програмування Python. Навчальний матеріал у ньому систематизований за розділами і є введенням у програмування від основ до поглиблених тем.

Розділи включають у себе: теоретичні відомості з практичними прикладами, контрольні запитання, вправи і задачі для самостійного виконання, довідкові матеріали.

Зразки розв’язування вправ і задач, які наведені у підручнику, можна переглянути у програмному застосунку Simple File Manager , що є додатком до підручника. Якщо Ви бажаєте відразу перейти до практики і перевірити свої сили у створенні програм мовою Python, використайте Практикум з програмування мовою Python .

Підручник призначений як для програмістів-початківців так і для тих, хто вже створював програми на інших мовах програмування, але бажає перевірити своє розуміння алгоритмів, використовуючи мову Python.

Робота із підручником передбачає, що Ви:

Володієте навичками роботи в операційній системі (Windows або Linux) на рівні користувача.

Підручник стане у нагоді всім, хто зацікавлений у вивченні популярної мови програмування Python, незалежно від того, чи вивчали ви інші мови програмування раніше.

Объяснение:

Цей електронний підручник знайомить з мовою програмування Python. Навчальний матеріал у ньому систематизований за розділами і є введенням у програмування від основ до поглиблених тем.

Розділи включають у себе: теоретичні відомості з практичними прикладами, контрольні запитання, вправи і задачі для самостійного виконання, довідкові матеріали.

Зразки розв’язування вправ і задач, які наведені у підручнику, можна переглянути у програмному застосунку Simple File Manager , що є додатком до підручника. Якщо Ви бажаєте відразу перейти до практики і перевірити свої сили у створенні програм мовою Python, використайте Практикум з програмування мовою Python .

Підручник призначений як для програмістів-початківців так і для тих, хто вже створював програми на інших мовах програмування, але бажає перевірити своє розуміння алгоритмів, використовуючи мову Python.

Робота із підручником передбачає, що Ви:

Володієте навичками роботи в операційній системі (Windows або Linux) на рівні користувача.

Підручник стане у нагоді всім, хто зацікавлений у вивченні популярної мови програмування Python, незалежно від того, чи вивчали ви інші мови програмування раніше.

Popov Valentina1324

4:

var a: array [1..3] of integer;

   i,min,max : integer;

begin

   for i:= 1 to 3 do

   begin

       write('a[',i,'] = ');

       read(a[i]);

       writeln;

   end;

   min:= a[1];

   max:= a[1];

   for i:= 1 to 3 do

   begin

       if a[i] < min then

       begin

           min:= a[i];

       end;

   end;

   for i:= 1 to 3 do

   begin

       if a[i] > max then

       begin

           max:= a[i];

       end;

   end;

   writeln('min = ',min);

   writeln('max = ',max);

end.

5:

var a: array [1..5] of integer;

   i,max : integer;

begin

   for i:= 1 to 5 do

   begin

       write('a[',i,'] = ');

       read(a[i]);

       writeln;

   end;

   max:= a[1];

   for i:= 1 to 3 do

   begin

       if a[i] > max then

       begin

           max:= a[i];

       end;

   end;

   writeln('max = ',max);

end.

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Определите, количество чисел k, для которых следующая программа выведет такой же результат, что и для k = 12? var k, i : longint; function f(n: longint): longint; begin f: = 3*n*n - 2*n; end; begin readln(k); i : = 1; while f(i) < k do i : = i + 1; if f(i)-k < = f(i-1) then writeln(i) else writeln(i-1); end.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Irinalobanowa
armsam76
dariagromova54
ecogoi
vdm4275
kapitan19
chernova1exei862
Люблянова_Р.1777
Давид-Александр
Asplaksina
sde19755511
unalone5593
Semenova
николаевич-Елена988
sergeykvik13