?>
Вариант 3. на¬пишите программу, которая в последовательности натуральных чисел определяет минимальное чётное число. программа получает на вход количество чисел в последовательности, а затем сами числа. в последовательности всегда имеется чётное число. программа должна вывести одно число — минимальное чётное число
Ответы
С++ / gcc 7.3.0
#include <iostream>
#include <algorithm>
#include <vector>
int main()
{
unsigned int N;
std::cin >> N;
std::vector<unsigned int> v(N);
for(unsigned int i = 0; i < N; i++)
std::cin >> v[i];
std::sort(v.begin(), v.end());
for(auto it : v)
{
if(it % 2 == 0)
std::cout << it << std::endl;
break;
}
return 0;
}