kulagin777
?>

Написать программу которая считает периметр и площадь треугольника по известным трем сторонам.

Информатика

Ответы

mashuska

program perimetr;

uses crt;

var a,b,c: real; p: real;

begin

writeln('ведите число');

read(a,b,c);

p: =a+b+c;

write(p)

end.

а с площадью все тоже самое.

polina0075880
1. короткий вариант // pascalabc.net 3.2, сборка 1439 от 09.05.2017 // внимание! если программа не работает, обновите версию! begin   seqrandom(10,-10,20).select(x-> (x,1/(newline) end. пример (13,0.0769230769230769) (-10,-0.1) (9,0.111111111111111) (-5,-0.2) (14,0.0714285714285714) (18,0.0555555555555556) (15,0.0666666666666667) (3,0.333333333333333) (-5,-0.2) (-9,-0.111111111111111) 2. "красивый" вариант // pascalabc.net 3.2, сборка 1439 от 09.05.2017 // внимание! если программа не работает, обновите версию! begin   seqrandom(10,-10,20).select(x-> (x,1/x))           .foreach(x-> writeln(x[0]: 3,x[1]: 15: 8)) end. пример   18        0.05555556 -10      -0.10000000   16        0.06250000   6        0.16666667   15        0.06666667   13        0.07692308   5        0.20000000   18        0.05555556   -1      -1.00000000   13        0.07692308 3. а так писали наши деды четверть века var   i,x: integer; begin   randomize;   for i: =1 to 10 do begin       x: =random(31)-10;       writeln(x: 3,1/x: 15: 8)       end end. пример   -7      -0.14285714   11        0.09090909   -2      -0.50000000 -10      -0.10000000   14        0.07142857   -7      -0.14285714   -5      -0.20000000   5        0.20000000   13        0.07692308   10        0.10000000
choia
Var   n,m,i,k: integer; begin   write('n='); read(n);   write('вводите числа через пробел или enter: ');   k: =0;   for i: =1 to n do begin       read(m);       if m mod 2=1 then           if frac(sqrt(m))=0 then inc(k)       end;   writeln('найдено квадратов нечетных чисел: ',k) end. пример n=10 вводите числа через пробел или enter: 16 49 1 5 9 121 66 71 0 -1 найдено квадратов нечетных чисел: 4

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Написать программу которая считает периметр и площадь треугольника по известным трем сторонам.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

Никитина580
anadtacia03108988
chizhenkovd9
andre6807
Anastasiya
metrikajulia
suhovaab
samuilik-v
makscska22879
endyurans2ooo
Salko17
Елена Ирина
ilysozkn27
saniopt
gresovanatalya