?>
Сумма чисел - 4 / используя цикл for/ необходимо написать программу, которая вычислит сумму 1 + 1 / 3 + 1 / (3 * 3) + 1 / (3 * 3 * + 1 / ( делить 3 в степени n) вводится натуральное число n (1≤n≤105 программа должна вывести результат вычисления одним вещественным числом с точностью до шести знаков после запятой. 5 1.497942
Ответы
#include <stdio.h>
#include <stdlib.h>
int sover (int n)
{
int sum = 0;
for (int i = 1; i<=n/2; i++)
if (n%i==0) sum+=i;
if (sum==n)
return 1;
else return 0;
}
int main()
{
int n;
printf ("N = ");
scanf ("%d",&n);
if (sover(n)==1)
printf ("Sovershennoe");
else printf ("Ne sovershennoe");
printf("\n");
system ("PAUSE");
return 0;
}
2)
#include <stdio.h>
#include <stdlib.h>
int main()
{
for (int i = 1; i<=5; i++)
{
for (int j = 1; j<=5-i+1; j++)
printf ("%d ",5+i-1);
printf ("\n");
}
system ("PAUSE");
return 0;
}