roman-fetisov2005
?>

Найти разность между суммой четных и суммой нечетных цифр заданного числа. написать программу в паскаль.

Информатика

Ответы

takerra
//Обьявляем дополнительные переменные и главный массив, а также два дополнительных - они будут "половинками".
var
  a, b, c: array [1..100] of longint;
  i, min, n, j, t: longint;

begin
  //Читаем количество элементов в нашем массиве.
  readln(n);
 
  //Читаем массив.
  for i := 1 to n do read(a[i]);
 
  //Заполняем первую "половинку".
  for i := 1 to n div 2 do b[i] := a[i];
 
  //Заполняем вторую "половинку". Но раз это уже вторая "половинка" главного массива, то и
  //цикл теперь должен начинаться со второй части массива, а заканчиваться уже в его конце.
  for i := n div 2 + 1 to n do c[i - n div 2] := a[i];
 
  //Теперь отсортируем первую "половинку" методом выбора. Идея этого метода
  //основывается на том, что мы ищем минимальный среди неотсортированных элемент,
  //а затем просто swap-аем его с тем, который стоит сразу после отсортированных.
  for i := 1 to (n - 1) div 2 do
  begin
    min := i;
    for j := i + 1 to n div 2 do
      if b[min] > b[j] then
        min := j;
    if min <> i then begin
      t := b[i];
      b[i] := b[min];
      b[min] := t;
    end;
  end;
 
  //Затем вторую точно также, только стоит обратить внимание на сравнения.
  //Так как надо отсортировать по убыванию, то теперь сравнение перед "swap"-ом
  //будет другим.
  for i := 1 to (n - 1) div 2 do
  begin
    min := i;
    for j := i + 1 to n div 2 do
      if c[min] < c[j] then
        min := j;
    if min <> i then begin
      t := c[i];
      c[i] := c[min];
      c[min] := t;
    end;
  end;
 
  //А теперь просто по очереди выводим готовые "половинки", не забывая ставить
  //пробел после вывода каждого элемента.
  for i := 1 to n div 2 do write(b[i], ' ');
  for i := 1 to n - n div 2 do write(c[i], ' ');
end.
lbeglarova6

1)Расстояние от ваших глаз до монитора должно составлять не менее 50 см. Обычно рекомендуется от 60 до 100 см.

Чистые руки (сухие)

Пустой стол.

Прямая спина

2)Эргономика – очень важная для современного мира наука. Ее усилия направлены на то, чтобы произвести работу или продукт наиболее качественно, затратив на это минимум энергии. Вопросы комфорта, правильной организации труда и среды обитания человека – это вопросы эргономики.

3)Когда человек использует приборы от них идут магнитные волны)))

4)Чтобы не портить здоровье. Не сильно сажать зрение, не искривлять позвоночник и т.д.  

Ответить на вопрос

Поделитесь своими знаниями, ответьте на вопрос:

Найти разность между суммой четных и суммой нечетных цифр заданного числа. написать программу в паскаль.
Ваше имя (никнейм)*
Email*
Комментарий*

Популярные вопросы в разделе

ann328389
Nadegdasb
pucha5261
Елена
nalekseeva62
BirUlek215
guujuu
Болеславовна
Vladimirovich1898
Сергеевна-Иван1045
Shelchkowa453
Sokolova-Shcherbakov
ak74-81
Alisa
sharaeva-is
▲